libRooFitMore cannot be loaded

Hi all. I’m using ROOT 6.22/02 and RooFit package on lxplus CERN service. I need to perform a convolution with RooFFTConvPdf but when I run the macro doing it, I got this error message

Error in TUnixSystem::FindDynamicLibrary: libRooFitMore[.so | .dll | .dylib | .sl | .dl | .a] does not exist in /usr/lib64/root:.:/usr/lib64/root:/lib64/tls/x86_64:/lib64/tls:/lib64/x86_64:/lib64:/usr/lib64/tls/x86_64:/usr/lib64/tls:/usr/lib64/x86_64:/usr/lib64
[#0] ERROR:Integration – RooNumIntFactory::Init : libRooFitMore cannot be loaded. GSL integrators will not beavailable !

The lines involved are

RooRealVar a(“a”,“a”,-0.5,-4.,-0.5) ;
RooRealVar a1(“a1”,“a1”,0.5,0.,5.);
RooRealVar a2(“a2”,“a2”,0.5,0.,3.);
RooRealVar a3(“a3”,“a3”,1.);
RooGenericPdf erf1(“erf1”,“Generic PDF”,"(a3+TMath::Erf(a1*(lifetime-a2)))TMath::Exp(alifetime)",RooArgSet(lifetime,a,a1,a2,a3));
RooRealVar mean(“mean”,“mean”,0.);
RooRealVar sigma(“sigma”,“sigma”,0.5,0.,1.) ;
RooGaussian gauss(“gauss”,“gauss”,lifetime,mean,sigma) ;
RooFFTConvPdf exg(“exg”,“erf1(X) gauss”,lifetime,erf1,gauss) ;

The last line causes the error.
Is it a problem of root version or should I explicitly include some library?
Thank you very much for your help.


Sorry, but ROOT installation on lxplus doesn’t have enabled mathmore option which is enabling roofitmore

 * LXPLUS Public Login Service -
* A C8 based is now available
* Please read LXPLUS Privacy Notice in
* Tuesday November 24th will terminate -
* ********************************************************************
-bash-4.2$ root-config --features
cxx11 asimage builtin_clang builtin_llvm dataframe davix dcache exceptions fftw3 fitsio fortran gdml gfal gnuinstall gsl_shared gviz http fcgi mathmore memstat mlp minuit2 mysql odbc opengl pgsql pyroot pythia8 r roofit shadowpw shared soversion sqlite ssl tmva tmva-pymva tmva-rmva spectrum unuran vmc x11 xml xrootd

Ok, thank you for the answer. Can I install this option? Thank you.

If fact I was not correct, I just noticed that mathmore is enabled…Sorry for the confusion!
But still, RoofitMore is not configured @ lxplus:

-bash-4.2$ ls -la /usr/lib64/root/libRooFit*
-rw-r--r--. 1 root root     748 Oct  3 10:48 /usr/lib64/root/libRooFitCore_rdict.pcm
-rw-r--r--. 1 root root   11391 Oct  3 10:48 /usr/lib64/root/libRooFitCore.rootmap
lrwxrwxrwx. 1 root root      21 Nov 10 02:56 /usr/lib64/root/ ->
lrwxrwxrwx. 1 root root      24 Nov 10 02:56 /usr/lib64/root/ ->
-rwxr-xr-x. 1 root root 6175768 Oct  3 18:43 /usr/lib64/root/
-rw-r--r--. 1 root root     732 Oct  3 10:54 /usr/lib64/root/libRooFit_rdict.pcm
-rw-r--r--. 1 root root    8946 Oct  3 10:54 /usr/lib64/root/libRooFit.rootmap
lrwxrwxrwx. 1 root root      17 Nov 10 02:56 /usr/lib64/root/ ->
lrwxrwxrwx. 1 root root      20 Nov 10 02:56 /usr/lib64/root/ ->
-rwxr-xr-x. 1 root root 2753376 Oct  3 18:43 /usr/lib64/root/

If you would like you can try to compile ROOT by yourself, and add to CMake command -Dmathmore=ON -Droofit=ON

Ok, I’ll try. Thank you very much.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.