Library not found for -lCore

I posted about a week ago, but I think my post might have been confusing as to exactly what the problem is. I am still in the early learning stages of working with C++ and ROOT. I thought I would repost more clearly what the issue is.

I recently formatted and installed Mac OS X 10.5 (Leopard) on my computer, and had to reinstall ROOT. I installed version 5.17.08 from the source, following the instructions. I have XCode 3.0 and 2.5 installed, and the I haven’t changed X11 from what comes with the OS install (I saw that on ROOT Talk Digest). I also installed gcc and g77 following

I have the following for $PATH, $ROOTSYS, $LD_LIBRARY_PATH and $DYLD_LIBRARY_PATH:
bash-3.2$ echo $ROOTSYS
bash-3.2$ echo $PATH
bash-3.2$ echo $LD_LIBRARY_PATH
bash-3.2$ echo $DYLD_LIBRARY_PATH

(when I cd into these folders, they do work and I am in the ROOT directory.)

Now, when I run my makefile, I get the following output:
gcc -o data/zprime.exe -O -lg2c zprime.o coup.o dec.o pdf.o Cteq6Pdf-2004.o integrate.o rootset.o cross.o print.o rcuts.o hist.o thesis.o paper.o -L-L/Users/travismartin/root/lib -lCore -lCint -lRIO -lNet -lHist -lGraf -lGraf3d -lGpad -lTree -lRint -lPostscript -lMatrix -lPhysics -lfreetype -pthread -lm -ldl -L/usr/local/lib
ld: library not found for -lCore
collect2: ld returned 1 exit status
make: *** [zprime.exe] Error 1

(I have bolded the ROOT library part that I think shows the problem.)

I am not sure what the problem is, as I haven’t changed my makefile, and this same setup used to work when I was running OS X 10.4 (Tiger). Can anyone see the problem?

Sorry to fill up the board with two posts on the same issue, but I have tried everything I know and everything my fellow grad students know to try to get this to work. We are all stumped. One of them has ROOT running successfully on Leopard, and I know it is supposed to work, so I am wondering where I went wrong. (Lesson to self - don’t upgrade OS while working on the data for a paper.)[/b]

Are you sure of the double “-L-L” ?

-L-L/Users/travismartin/root/lib -lCore


No, I am not sure. I don’t know why it is there and I can’t figure out how to remove it.

Someone else set up my makefile for me, and it used to work under Tiger, so I am just assuming it is something with how I setup Leopard.

Hi Rene,

I spent a while today going through the make file, trying tcsh and bash, and mucking with my .bashrc and .cshrc files.

You are right - the -L-L is not correct. In my makefile, I have the following lines: (only the important lines included, for brevity, the rest don’t matter and seem to be working fine)

ROOTLIBS = -L$(shell root-config --libs)

g++ -o data/$(NAME) -O -lg2c $(OBJECTS) $(ROOTLIBS) -L/usr/local/lib

The $(ROOTLIBS) is what is resolving as -L-L/Users/travismartin/root/lib

Now, I mucked around with things, and I took out the ROOTLIBS and manually typed in the paths. However, I get the same result. Could it be a problem with my version of MAKE? (If so, I will apologize and thank you kindly for the help and stop bothering this support forum.) But it seems to be something wrong with the path setup for root.

Well, I got it working. Apparently, root-config --libs is different on my current install than it was on my previous one.

I have other issues, but they are related to gcc and not ROOT, so I will just say thanks.