cannot open shared object file: No such file


I want to use Pyroot on my /afs/ account :
Python 2.3.4
[GCC 3.4.6 20060404 (Red Hat 3.4.6-3)] on linux2

it worked before with the following lines in my .bashrc (with 5.12.00e/slc4_ia32_gcc345):

export LD_LIBRARY_PATH=/usr/local/lib:root-config --libdir:$LD_LIBRARY_PATH
export PYTHONPATH=$PYTHONPATH:root-config --libdir

now, when I call for the ROOT module I get the message :

import ROOT
Traceback (most recent call last):
File “”, line 1, in ?
File “/afs/”, line 75, in ?
from libPyROOT import *
ImportError: /afs/ cannot open shared object file: No such file or directory

But the file is actually there. I also tried with other root versions.

Any suggestions?




the machines that “” points to have changed a little while ago. They are no longer ia32 boxes, so the target “slc4_ia32_gcc345” and its underlying binaries will not work. Please use “slc4_amd64_gcc34” instead. You can look at /proc/cpuinfo to see what kind of machine you have (amd64 and Intel Xeon 64bits are compatible).