loading problem in root 4 at mac os X

I compiled the root from root 4.00/04 source code on my mac os x 10.3.
with gcc 3.3 coming from apple develop tools.

I did the following when compiling

$ cd root
$ export ROOTSYS=pwd
$ export PATH=$ROOTSYS/bin:$PATH
$ ./configure macosx --prefix=/usr/local/root
$ make
$ make install
$ export ROOTSYS=/usr/local/root
$ export DYLD_LIBRARY_PATH=$ROOTSYS/lib/root
$ export PATH=$ROOTSYS/bin:$PATH

Everything goes fine and I think I compiled it sucessfully.

After that, I run root, then I tried to load inside root by

.L /usr/local/root/lib/root/

I got such an error message

dlopen error: dlcompat: dyld: /usr/local/root/bin/root.exe Undefined symbols:

Load Error: Failed to load Dynamic link library /usr/local/root/lib/root/
*** Interpreter error recovered ***

I tried tp compile my old standalone programs using this root, they work

I also found out that when I load other .so files, like, etc. It works also fine. But when I tried to load, the almost same error appeared.

Can somebody give a hint on how to solve this?

Thanks in advance.


This is a MAC specific problem that should be solved in the current CVS. A possible workaround is to do:


It works. Thanks a lot!