libCore problem on ROOT 5.14/5.15 on OS X 10.4 (Power PC)

I have recently tried downloading and running ROOT 5.14 and 5.15 on my Power PC based Powerbook, running OS X 10.4.9.

I unpack the tar file into /usr/local/root, and also set the environmental variables ROOTSYS and DYLD_LIBRARY_PATH to their appropriate values.

This is what I get when I run ROOT:

dyld: Library not loaded: /afs/
Referenced from: /usr/local/root/lib/libCore.dylib
Reason: image not found

I would greatly appreciate any suggestions you might have, thanks!


the LCG provided binaries run only on AFS connected machines, not standalone. To get ROOT running on your powerbook just compile ROOT from source. Or download ROOT from:

Cheers, Fons.

Dear Fons,
It seems the Mac OS X/ppc version of ROOT 5.16 available here also needs AFS as a dependency.
Is this the way intended, or might have a wrong build been uploaded ?

It should not depend on AFS at all. Do you have AFS on your machine?

– Fons


The ppc version is built by Bertrand and it depends on files on AFS.
I built the Intel versions without AFS.

I discussed with Bertrand the generation of the export tar files without AFS.
He will consider it, but for the LCG releases, it must be with AFS.


Thanks for your support.
In the meantime, I will build from source for my ppc machines.

The PPC version on the ROOT download page is now without AFS references.

Cheers, Fons.