Landscape mode when printing to pdf

to avoid a new topic… I revive this old one.

writing my thesis I belive .pdf-vector graphics is the best format for my ROOT-made histograms.
So using xelatex, I find that the images automatically are rotated, a hardcoded setting, as can be seen on the attachment.
Found on web this, from 3 years ago. This behavior continues…

Any suggestions? From editor/‘save as…’/code solutions?

p.s. this does not happen with .eps. Also this doesnot happen with luatex( pdf or eps).


A new one would be better. This one was closed… anyway …

I am not using xelatex … I can have a look…
Can you provide a small example (text file and pdf image) reproducing this problem ?
I will then try 1st with pdflatex

For xelatex on windows, with miktex 2.9, the error is

Process started: xelatex.exe -synctex=1 -interaction=nonstopmode "test-pdf-rotate90".tex stdin -> test-pdf-rotate90.pdf [1 xdvipdfmx:warning: << /Rotate 90 >> found. (Not supported yet) ] 15229 bytes written Process exited normally
and the output is on the files attached.
I ask since xelatex is a major tex compiler.

p.s. As before with lualatex, pdflatex does not have this problem on the same system.

test-pdf-rotate90.tex (286 Bytes)
1.pdf (14.9 KB)

Pdflatex works fine for me on Mac. With xelatex I get an empty page…
it looks like a bug in xelatex ?

Maybe… and most possible this is a tex-forum related question.

The only thing I am sure of is that the root-produced pdf has this hardcoded “parameter” ‘45 Rotate: 90’ that is seen on the first screenshot.

Anyway, mayby the workaround is to avoid xelatex and use luatex (pdflatex is not considered a good option for multiple languages nowdays).