Ktjet and Root (cygwin on winXP)

I’d like to use the ktjet package within root. I tried with cygwin on my laptop (winXP) but don’t know really how… Help is wellcome!
This is what I did:

  1. installed cygwin today (latest version) on my laptop and root binaries (WindowsXP/NT/w2000 with CYGWIN and gcc3.2 version 4.00/06a)

  2. root is ok up running (only problem is “ldd: not found”, which is mentioned on RootTalk but no solution yet?)

  3. installed CLHEP needed to compile ktjet: wwwasd.web.cern.ch/wwwasd/lhc++/ … .8.2.0.tgz and everything seems OK

  4. installed ktjet, compiled and tested with example from the site: jetweb.hep.ucl.ac.uk/ktjet/index.html (see download and example links). Everything is OK and I have the library libKtEvent.a which is what I’d like to use from root and cint

  5. Run root and tried (is that the right thing to do?):
    root [0] gSystem->Load(“libKtEvent”)
    dlopen error: dlopen, Win32 error 193
    Load Error: Failed to load Dynamic link library /home/santocch/ktjet/lib/./libKtEvent.a
    *** Interpreter error recovered ***

Now what? I don’t have much experience so I need some hint on this problem…
Thank you


You should link a shared lib libKtEvent.so and not an archive lib libKtEvent.a


OK, thank you for the answear…
I tried to build the shared librarly for ktjet and I know that this is probably not the right place but maybe someone is able to help:
I tried to use ld -shared to build the shared library but I get errors…
Could someone provide an example of makefile to use with the ktjet package to build the shared library?
Thank you again…


Hi Attilo,
clhep doesn’t know automatically how to build for cygwin. You have to run

GXX=g++ LD=g++ LDFLAGS=shared CXXFLAGS= ./configure
Also, as you assumed, you have to modify ktjet’s makefile. You can find the libraries and the modified Makefile here [www-clued0.fnal.gov]. Keep in mind that you need a dictionary if you want to store an object of a type defined in any of these libs, or if you want to use these libs interactively. Creating a dictionary for clhep is no easy project; I’d rather suggest that you replace clhep with root in ktjet (instead of clhep’s lorentz vector you use TLorentzVector etc). Regarding your other problem:

[quote]root is ok up running (only problem is “ldd: not found”, which is mentioned on RootTalk but no solution yet?)
This is solved in recent root versions (see e.g. the binaries for 4.01/02).

Thank you for helping… I’ll try soon all of your suggestion… (btw I suppose that you are the Axel author of the windows-root site reported on download… great work!