Installing ROOT on Ubuntu

Dear experts,

I tried to re-install ROOT on my computer (someone else installed it for me the first time). I have Ubuntu 13.10 and so I chose the source file from version 5:

There were many posts about installing root but they were a bit confusing so I chose the standard way with these commands:

tar zxvf root_v5.34.36.source.tar.gz
cd root

sudo apt-get install git dpkg-dev make g++ gcc binutils libx11-dev libxpm-dev \
libxft-dev libxext-dev

sudo apt-get install gfortran libssl-dev libpcre3-dev \
xlibmesa-glu-dev libglew1.5-dev libftgl-dev \
libmysqlclient-dev libfftw3-dev cfitsio-dev \
graphviz-dev libavahi-compat-libdnssd-dev \
libldap2-dev python-dev libxml2-dev libkrb5-dev \
libgsl0-dev libqt4-dev

./configure --help
./configure linux

Finally, Root was installed but when I tried to execute some of my files there where several errors because many libraries where missing. Obviously I missed something during installation.
So is there someone who could write the exact commands for installing a functional ROOT from the beginning?

Thank you in advance

Pepe Le Pew thank you for your answer again. I’m in your debt.
I’m guessing you refer to the commands:

sync && sudo apt-get clean && sudo apt-get update && sudo apt-get check && sudo apt-get dist-upgrade && sudo apt-get upgrade && sync

sudo apt-get install tcsh gawk cmake
sudo apt-get build-dep root-system

So I could just try them at this point??

Well I updated to Ubuntu 14.04 and I did the installation again.
The problem is that some header files (RooGaussian.h, RooRealVar.h, etc) are missing from the directory “include” of root. In fact I think they are from Roofit.
Is there a way to add them now or should I install Root again and enable roofit somehow??

Well I just installed root again but instead of using:


I used this time:

./configure --fail-on-missing --enable-genvector --enable-mathmore --enable-minuit2 --enable-python --enable-roofit --enable-tmva --enable-xml --enable-xft --enable-x11

And all my problems were solved…