Home | News | Documentation | Download

Installing root. ld: symbol(s) not found for architecture arm64

I was building root 6.24 from the source using Mac m1 with xcode13.0. I tried from source because there is no binary available for macOS Monterey.
The installation was completed successfully but I miss to add the python lib to call PyRoot so I added the python executable path and try to rebuild. But the installation stopped by the error,

 ld: symbol(s) not found for architecture arm64

clang: **error:** **linker command failed with exit code 1 (use -v to see invocation)**

make[2]: *** [lib/libPyMVA.so] Error 1

make[1]: *** [tmva/pymva/CMakeFiles/PyMVA.dir/all] Error 2

Is there any way to remove this error ?

Hi @vinay_krishna,

First of all, the recommended method for installing ROOT in MacOS X is via package managers (see instructions here: Installing ROOT - ROOT).
Building ROOT from sources is typically discuraged for regular use (unless there is a major reason to do so). :slight_smile:

That said, are you seeing anything else prior to that error?

Cheers,
J.

Hi, thanks I tried with sudo port install root6. The root was installed successfully but I cannot call pyROOT using python. For this do I have to do any additional step ?

Which version of Python are you using? You can also try installing ROOT via a Conda package.

In my system I have python3.9. And I tried with the Conda, which helps to successively install pyROOT. but after that most of the Machine learning packages such as Keras and tensorflowr can not installed using Conda, in Mac OS monetary.

Hi @vinay_krishna ,
probably you have to install those machine learning packages in the same conda environment in which you installed ROOT.

Cheers,
Enrico