Installing ROOT in UBUNTU

Hi All,

I am trying to install root using the instruction on the root home page by compiling the source code. I have managed to get the the final bit but when I try to execute the command make install I get the the following error:

/usr/bin/ld: cannot find -lXft
collect2: ld returned 1 exit status
make: *** [lib/libGX11.so] Error 1

could some one please help.

Many thanks,
Israel.

Hi Israel

You are missing the X freetype library (or the configure utility cannot find it on your system). Freetype fonts are used for antialisaling fonts.

What you can do is to add in your “configure” command line “–enable-builtin-freetype”. You shoud do this before typing make.
Eg:

configure --enable-builtin-freetype
make
make cintdlls
make map

I suggest you to type “configure --help” before to see all available flags besides the “–enable-builtin-freetype”

Cheers

Hi Israel,

which Ubuntu version are you trying to compile it for? I am asking, because there are precompiled packages available for Ubuntu Edgy (6.10) and Feisty (7.04) at

mirror.phy.bnl.gov/debian-root/

If you need any help with those, feel free to ask. Unfortunately there are no packages available for Ubuntu Dapper (6.06), so you would have to build those yourself.

Since ROOT will very likely be packaged for Debian unstable at the end of June, I hope that Ubuntu will be able to sync it for the next release, which would be 7.10. That way, ROOT would be available right from Ubuntu’s own repositories, just like all other software.

Cheers,
Frank

hi Matthieu and Frank,

Thanks for your reply. I tried the --enable option but it is still giving me the same error message. I am using
Distributor ID: Ubuntu
Description: Ubuntu 7.04
Release: 7.04
Codename: feisty

Is there any where that I can get the library, google search is giving me 0 hits.

Cheers,
Israe,

Have try to install libxft-dev package?

As I said above, precompiled root packages for Ubuntu 7.04 i386 are available from mirror.phy.bnl.gov/debian-root/.
If you are not familiar with adding software repositories to Ubuntu’s package management, take a look at

help.ubuntu.com/7.04/add-applic … dding.html

The repository’s “APT line”, which it is asking for, is

After that, root-system should be installable from the package manager (only libroot-python-dev is uninstallable, but you won’t need it).

Cheers,
Frank

Thank you Frank,

I have now got the precompiled installed and it is working.

Cheers,
Israel.

:hot_face: :hot_face: :hot_face:I am trying to install root but hte configuring is incomplet
cmake …/root-6.20.04/ -Dall=ON
– Could NOT find Git (missing: GIT_EXECUTABLE)
– Looking for python
CMake Error at /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
Could NOT find PythonLibs (missing: PYTHON_LIBRARIES PYTHON_INCLUDE_DIRS)
Call Stack (most recent call first):
/usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.10/Modules/FindPythonLibs.cmake:262 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
cmake/modules/SearchRootCoreDeps.cmake:87 (find_package)
CMakeLists.txt:120 (include)

– Configuring incomplete, errors occurred!
See also “/home/jaouad/root/CMakeFiles/CMakeOutput.log”.

sudo apt-get install git python3-dev