Home | News | Documentation | Download

Installing ROOT from the source


Please read tips for efficient and successful posting and posting code

ROOT Version: V6.22.08
Platform: Centos
Compiler: Not Provided


Hi all, I am trying to install ROOT from the source file because it is necessary to use the event generator GENIE software.
So I download the file root_v6.22.08.source.tar.gz
then I use tar -xvzf
then I create the directory root_v6.22.08-build and cd to this directory

i use the following command:
cmake -Dgdml=ON -Dbuiltin_gsl=OFF -Dmathmore=ON -Dpythia6=ON -Dpythia8=ON -Droofit=ON -DGSL_DIR=/home/jordi/genie_software/gsl-2.6/ -DGSL_CONFIG_EXECUTABLE=/home/jordi/genie_software/gsl-2.6/bin/gsl-config -DPYTHIA6_LIBRARY=/home/jordi/genie_software/pythia6428/libPythia6.so -DPYTHIA8_DIR=/home/jordi/genie_software/pythia8304-source/ -DPYTHIA8_INCLUDE_DIR=/home/jordi/genie_software/pythia8304-source/include/ -DPYTHIA8_LIBRARY=/home/jordi/genie_software/pythia8304-source/lib/libpythia8.so -DCMAKE_INSTALL_PREFIX=/home/jordi/genie_software/root-6.22.08/ …/root-6.22.08/

then:
make -j12

and everything seems to work but in the 93% this happens:

I don’t find any information about this error, so thanks for any help.

Hi @Jordi_Suazo,

You ran $ make -j12, which means that up to 12 processes will be spawned by make. Consequently, there might be some output between the point an error occurs and

make: *** [Makefile:171: all] Error 2

That said, could you take a look at the latest lines in the output and copy here any relevant lines (compiler diagnostic messages, etc.)?

Cheers,
J.

hi, so i ran again only using $make, and this happens:


thanks for any help

Hi @Jordi_Suazo,

Which compiler (and version) are you using to build ROOT? You can see the path to the compiler in the CMake output or running $ grep CMAKE_CXX_COMPILER CMakeCache.txt from your build directory. Please provide here the output of:

$ /path/to/your/compiler/c++ --verbose

Also, which version of CentOS are you building ROOT on?

Cheers,
J.

Hi, here is the information:

thanks

Hi @Jordi_Suazo,

You did not provide the compiler version that you are using, although I think that the one provided by devtoolset-8 is g++ 8.3.1. I think that building ROOT on CentOS 6 is not officially supported. Furthermore, building ROOT via devtoolset is known to have some issues. In particular, to me it seems to be using the C++ headers provided by the old compiler toolchain.

Cheers,
J.

Hi @jalopezg, sorry about that… you’re right the compiler version provided by devtoolset-8 is g++ 8.3.1… so
is there any recommendation that you think can help me?,

thanks for the help.

also, if I ran only using $make now this happens:

Hi,

I follow the same steps describe before but for version 6.24.00 and this time it installed, I think, successfully:

but now I have a problem trying to compile GENIE against ROOT, I know this a ROOT forum but I think the problem is related to ROOT (sorry if it is not):

the issue is that I receive this error message:


Really appreciate any help.