Installing root error:

I need some assistance installing root. I have installed root three times in other machines but now this time it seems that the installation is not running as smooth as in the other machines. This machine has the new fedora core 7 as you can see next:

[root@oh-henry root]# uname -a
Linux #1 SMP Fri Jul 27 18:10:34 EDT 2007 i686 i686 i386 GNU/Linux

What happens is that I get the following error after I have done the following procedures
./configure … done successfully
./ make … done successfully
./make install… I get the following error:

==> lib/ done
Generating dictionary x11/src/G__X11.cxx…
utils/src/rootcint_tmp -cint -f x11/src/G__X11.cxx -c x11/inc/TGX11.h x11/inc/LinkDef.h
bin/rmkdepend -R -fx11/src/G__X11.d -Y -w 1000 –
-pipe -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -D__cplusplus -Icint/lib/prec_stl
-Icint/stl – x11/src/G__X11.cxx
g++ -pipe -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -I. -o x11/src/G__X11.o -c x11/src/G__X11.cxx
g++ -shared -Wl,-soname, -O -o lib/ x11/src/GX11Gui.o x11/src/Rotated.o x11/src/TGX11.o x11/src/gifdecode.o x11/src/gifencode.o x11/src/gifquantize.o x11/src/G__X11.o -lXpm -lXext -lX11 -lXft
/usr/bin/ld: cannot find -lXext
collect2: ld returned 1 exit status
make: *** [lib/] Error 1

I will really appreciate if you could provide me some assistance with this. Also notice I am not installing the lates version of root v:00.15 but I think I am installing root_v5.15.06.source.tar.gz

Thank you in advance,

For future reference, the problem was solved by creating a soft link.

I found out that -lXext is actually a library which is trying to be load using the loader ld. lXext expanded is actually

I tried to find this lib in my system (locate libXext) and it happen that I found
By making a soft link from to solved my problem. I actually used the same trick to solve other steps in the installation which were similar to this one.


DRDC Suffield