Installing Root challenges

Hello guys, i’m a novice and i’m struggling with installing root on Ubuntu. This is what i managed to get so far, after the command: make -j 4

If you are using make -j, please try a sequential build (make -j1). The truncated files may be because you ran out of memory and some compiler processes got killed while writing the output files. Also, linking rootcling_stage1 and are known to use lots of memory. Sometimes I’ve locked up my computer because I had multiple ROOT compilations going on in parallel and they both tried to link rootcling_stage1 and at the same time…

Thanks for the quick response Amadio, I tried but it still fails after 45% running and report the same error. Is there a way to remove the Truncated files and update them or just reset the installation and try again from scratch?

Yes, if you remove the directories containing the truncated files, it should succeed. Otherwise, you can run make clean and then make -j1.

Thank you for that, it seems to have helped because i got much further than i had; until i ran out of memory so i’m working on that and trying again.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.