INSTALLING ROOT 6.06/06 on Ubuntu 14.04

Dear all,

I am installing ROOT 6.06/06 on Ubuntu 14.04. 

I have gcc 4.8.4
cmake 5.2
python 2.7.6

I follow the instruction

  1. Get the sources of latest ROOT (see above)

  2. Now type the build commands:
    cmake …/root -DCMAKE_INSTALL_PREFIX= -Dgnuinstall=ON
    cmake --build . [ or simply “make -j” on Unix systems ]

And everything goes fine, but when I run:
cmake --build . --target install

I get

– Up-to-date: /opt/Software/Scientific/ROOT/6.06.06/installation_folder/include/root/TMathBase.h
– Up-to-date: /opt/Software/Scientific/ROOT/6.06.06/installation_folder/include/root/TExec.h
– Up-to-date: /opt/Software/Scientific/ROOT/6.06.06/installation_folder/include/root/TCanvasImp.h
– Up-to-date: /opt/Software/Scientific/ROOT/6.06.06/installation_folder/include/root/TTime.h
– Up-to-date: /opt/Software/Scientific/ROOT/6.06.06/installation_folder/include/root/TMemberInspector.h
– Up-to-date: /opt/Software/Scientific/ROOT/6.06.06/installation_folder/include/root/TVirtualPS.h
– Up-to-date: /opt/Software/Scientific/ROOT/6.06.06/installation_folder/include/root/TParameter.h
– Up-to-date: /opt/Software/Scientific/ROOT/6.06.06/installation_folder/include/root/TNamed.h
– Up-to-date: /opt/Software/Scientific/ROOT/6.06.06/installation_folder/include/root/Riostream.h
– Up-to-date: /opt/Software/Scientific/ROOT/6.06.06/installation_folder/include/root/TRegexp.h
– Up-to-date: /opt/Software/Scientific/ROOT/6.06.06/installation_folder/include/root/TVirtualPad.h
– Up-to-date: /opt/Software/Scientific/ROOT/6.06.06/installation_folder/include/root/TPoint.h
CMake Error at core/utils/cmake_install.cmake:42 (file):
file INSTALL cannot find
Call Stack (most recent call first):
core/cmake_install.cmake:74 (include)
cmake_install.cmake:158 (include)

make: *** [install] Erreur 1

In effect I have no rootcling in /opt/Software/Scientific/ROOT/6.06.06/installation_folder/bin/, but only a rootcling_tmp

Could anyone help me, please?

Does anyone kn

Remove everything (including “/opt/Software/Scientific/ROOT/6.06.06”) and start from scratch again, this time using: cmake -DCMAKE_INSTALL_PREFIX="/opt/Software/Scientific/ROOT/6.06.06" -Dall="ON" -Dgeocad="ON" -Dbuiltin_ftgl="OFF" -Dbuiltin_glew="OFF" -Dsoversion="ON" ../root
BTW. If you installed the standard Ubuntu’s ROOT 5 version then first “completely remove” / “purge” (i.e. “remove with any associated configuration files”) all ROOT 5 related packages, i.e. execute “sudo apt-get purge root-system* root-plugin* libroot*” (afterwards check that the “/usr/lib/i386-linux-gnu/root5.34” and the “/usr/lib/x86_64-linux-gnu/root5.34” subdirectories disappeared completely).


It still gives me an error…

CMake Error at core/rint/cmake_install.cmake:52 (file):
file INSTALL cannot find
Call Stack (most recent call first):
core/cmake_install.cmake:73 (include)
cmake_install.cmake:169 (include)

make: *** [install] Erreur 1

I write exactly what I do:
I create a folder whose path is:

Inside this folder I have 2 directories:

I put root_v6.06.06.source.tar.gz inside source and “untar” it.
So, I end up with:

I go to /opt/Software/Scientific/ROOT/6.06.06/installation_dir
from inside there, I type:

sudo cmake -DCMAKE_INSTALL_PREFIX="/opt/Software/Scientific/ROOT/6.06.06/installation_dir/" -Dall=“ON” -Dgeocad=“ON” -Dbuiltin_ftgl=“OFF” -Dbuiltin_glew=“OFF” -Dsoversion=“ON” …/source/root-6.06.06/


sudo cmake --build .
and finally
sudo cmake --build . --target install

At this point, it complains and crushes.

Could anyone help me, pls?


I think that the “CMAKE_INSTALL_PREFIX” must be different / separate from the “” (e.g. create “/opt/Software/Scientific/ROOT/6.06.06/build_dir”).
If you want to build ROOT “in-place” then do not define “CMAKE_INSTALL_PREFIX” when configuring ROOT (and later do not call “cmake … install”).

Another thing.
I had a low version of cmake, therefore I had installed cmake 3.5.2.
The old version of cmake is in /usr/bin and the new in /opt/Software/Packages/usr/bin//cmake
In my .bashrc I put

export CMAKE_ROOT=/opt/Software/Packages/usr/share/cmake-3.5/
export PATH=/opt/Software/Packages/usr/bin/:/usr/bin/:$PATH
export LD_LIBRARY=/usr/lib/:/usr/share:/opt/Software/Packages/usr/lib:/usr/lib:$LD_LIBRARY

If I digit from my home

which cmake

If I ask the version:

cmake --version
cmake version 3.5.2

CMake suite maintained and supported by Kitware (

If I go to /usr/bin and ask

cmake --version

I get:

CMake Error: Could not find CMAKE_ROOT !!!
CMake has most likely not been installed correctly.
Modules directory not found in
cmake version 3.5.2

CMake suite maintained and supported by Kitware (

Is that normal, pls?


I use Ubuntu 14.04.5 LTS / x86_64 with it’s default packages, e.g. gcc 4.8.4, cmake, python 2.7.6 (as of today), I am able to build ROOT 6.06/06 without any problems.

Using cmake options that I gave you in my first post here, I get:

[…]$ root-config --version
[…]$ root-config --features
asimage astiff bonjour builtin_afterimage builtin_llvm cxx11 cling davix dcache exceptions explicitlink fftw3 fitsio fortran gviz gdml geocad genvector gfal http krb5 ldap mathmore memstat minuit2 mysql odbc opengl pch pgsql pythia8 python qt qtgsi roofit r shadowpw shared soversion sqlite ssl table thread tmva unuran vc vdt xft xml x11


The reason why I installed a higher cmake version is that later on should install also GEANT4.
I am not sure I understood your suggestion.
I am trying now in the following way:
I have a source_directory, build_directory and installation_directory.
From the build_directory I call the source and use installation_directory as prefix.

Was it this the idea, pls?

Yes, that should be fine. Just make sure that you first remove anything that exists now (so that there are no remnants from previous builds) and start from scratch again.

It worked :slight_smile:

Thanks a lot!


The compilation was successfull, but the I did sudo ldconfig and the typed root, and it told me

Le programme « root » n’est pas encore installé. Pour exécuter « root », veuillez demander à votre administrateur d’installer le paquet « root-system-bin »

But if I go to /installation_dir/bin and type ./root it starts.
Should I add it at the PATH in my .bashrc?
If so, should I add the installation_dir/bin or build_dir/bin, pls?


source /opt/Software/Scientific/ROOT/6.06.06/installation_dir/bin/