Installing ROOT 6.03.02 on OSX 10.10.3 with XCODE 6.3

Hi all,

sorry if I present again this topic, but I am a bit lost among the various posts…

Summarising, yesterday (17th of April) I updated my OSX to 10.10.3, installed XCODE 6.3 and XQuartz, and I tried to install ROOT 6.03.02, following the procedure I always used:

make -j 2
export ROOTSYS=/usr/share/root/root_6.03.02
make install

and I obtained the error:

TRegexp.cxx:146:4: error: thread-local storage is not supported for the current target thread_local char buf[fgMaxpat]

Because I didn’t use ROOT for a couple of years, I supposed that I made a mistake in the installation procedure, but searching in the forum I found there was a problem with XCODE.
If I understand correctly some posts, there is a way to fix it, but I did understand it…

So now I have some questions:
[li]Is the procedure I used correct?[/li]
[li]What is the way to fix that error? Or better…[/li]
[li]Which ROOT version is compatible with OSX 10.10.3 and XCODE 6.3?[/li][/ul]

Thank you very much for the help and sorry again I asked for a solved problem.
Best regards,

You need to take the head of the v6-02-00-patches branch or wait for the v6.02/10 release or downgrade XCode to 6.2.

Hi Wile,

thank you very much for the answer, I installed the v6-02-00-patches, it works!