Installing ROOT 5.14

Good day, I have the following problem: I need to run a piece of software (HVPTools) that was built to work with ROOT 5.14. I first tried to run HVPTools with the latest ROOT (5.34) on Linux Mint 14 (based on Ubuntu 12.10), but this did not work, as it complained of undefined mathematical functions (such as sqrt). Although this issue can be fixed by adding includes (include <math.h>), HVPTools still does not run (more errors). I therefore fear that there are other incompatibilities with HVPTools and newer versions of ROOT. Correcting the code for HVPTools to work with newer versions of ROOT is one option, but I do not know how to proceed.

The second option (that appears easier) is to get a system running with ROOT 5.14. However, I have had huge issues doing this. First, I can’t compile the ‘complete source tree’ on my Mint 14 (ie Ubuntu 12.10). When running ‘/.configure’ it complains that

Configuring for linuxx8664gcc Checking for libX11 ... no configure: libX11 (package x11-devel) MUST be installed
I have the libX11 package installed (I can compile the ROOT 5.34 source). I can’t solve this problem, and read in one of the forums that this was a bug in older versions of ROOT that give this error with new versions of Ubuntu, and that this has been fixed in newer ROOT versions. So I thought of using an older version of Ubuntu. I tried both Ubuntu 8.04 and 9.10. After using ‘sudo apt-get install’ to get all of the required packages (, I ran ‘/.configure’ (which seemed to run fine) and then ‘make’. However, this immediately complained that

make: g77 : command not found make: g77 : command not found make: g77 : command not found
then producing lots of output, and ending with

cint/src/Type.cxx:128:15: error: missing binary operator before token "(" cint/src/Type.cxx:141:15: error: missing binary operator before token "(" make: *** [cint/src/Type.o] Error 1
I don’t know what is going wrong here! I will also mention that I tried to get ROOT 5.14 working with Mac OS X 10.5.8, but it gave an error “[xrootd/src/xrootd/lib/] Error 2”. It was reccommended in some places to just disable xrootd (./configure --disable-xrootd). Although root now compiles, HVPTools does not work, as it probably requires xrootd…

Anyhow, this is my situation. Any help/advice proceeding from here would be greatly appreciated.

Regards, Sebastian.

Try SLC4, install “gcc-[c++,g77]-3.4.6” (do not install any “gcc4-*”).