Installing hadd and h2root

Hi,
I would like to use hadd and h2root. Could you give me instructions how to install them? I currently use ROOT version 5.32.
Thank you!
TM

The “hadd” should have been built in any case.
The “h2root” should have been built if any fortran compiler was found (e.g. gfortran or g77).
These executables should be present in the “${ROOTSYS}/bin” subdirectory. Try:
ls -al ${ROOTSYS}/bin/

No, hadd is not there automatically.

Here is the output of the command:
[pc172] /home/tmaki > ls -al ${ROOTSYS}/bin/
total 64
drwxr-xr-x 2 tmaki tmaki 4096 Mar 1 11:19 .
drwxr-xr-x 10 tmaki tmaki 4096 Mar 1 10:05 …
-rwxr-xr-x 1 tmaki tmaki 27231 Mar 1 11:18 root
-rwxr-xr-x 1 tmaki tmaki 9871 Mar 1 11:19 root.exe
[pc172] /home/tmaki >

There is something really wrong with your ROOT installation.
Except for “root” and “root.exe”, there should be (at least) something like “rootcint”, “root-config”, “thisroot.csh”, “thisroot.sh” (… and many more … among them “hadd”, “h2root”, “g2root”, …).
Try (if the “minicern” library was built then you should also have “h2root” and “g2root”):
ls -al ${ROOTSYS}/lib/libminicern.*
ls -al ${ROOTSYS}/lib/root/libminicern.*
Try also (one of them is needed in order to build the “minicern” library and then “h2root” and “g2root” - I assume here that you use Linux):
gfortran -v
g77 -v

I re-installed root, and now “hadd” works fine.

“h2root” is found, but it gives an error message “h2root: error while loading shared libraries: libminicern.so: cannot open shared object file: No such file or directory”. What should I do to make it work?

The content of the new bin directory is:
total 1248
-rwxr-xr-x 1 tmaki tmaki 37135 Apr 5 14:30 rmkdepend
-rwxr-xr-x 1 tmaki tmaki 25163 Apr 5 14:34 root-config
-rw-r–r-- 1 tmaki tmaki 3591 Apr 5 14:34 thisroot.sh
-rw-r–r-- 1 tmaki tmaki 4034 Apr 5 14:34 thisroot.csh
-rwxr-xr-x 1 tmaki tmaki 2854 Apr 5 14:34 setxrd.sh
-rw-r–r-- 1 tmaki tmaki 3834 Apr 5 14:34 setxrd.csh
-rwxr-xr-x 1 tmaki tmaki 8447 Apr 5 14:34 memprobe
-rwxr-xr-x 1 tmaki tmaki 92 Apr 5 14:34 genreflex-rootcint
-rwxr-xr-x 1 tmaki tmaki 83 Apr 5 14:34 genreflex
-rwxr-xr-x 1 tmaki tmaki 325380 Apr 5 14:37 rootcint
-rwxr-xr-x 1 tmaki tmaki 18369 Apr 5 14:37 rlibmap
-rwxr-xr-x 1 tmaki tmaki 27302 Apr 5 15:50 genmap
-rwxr-xr-x 1 tmaki tmaki 24556 Apr 5 15:51 root
-rwxr-xr-x 1 tmaki tmaki 194636 Apr 5 15:51 rootd
-rwxr-xr-x 1 tmaki tmaki 171090 Apr 5 15:51 proofd
-rwxr-xr-x 1 tmaki tmaki 9871 Apr 5 15:51 root.exe
-rwxr-xr-x 1 tmaki tmaki 99345 Apr 5 15:51 pq2
-rwxr-xr-x 1 tmaki tmaki 9866 Apr 5 15:51 rootn.exe
-rwxr-xr-x 1 tmaki tmaki 15857 Apr 5 15:51 proofserv.exe
-rwxr-xr-x 1 tmaki tmaki 2918 Apr 5 15:51 proofserv
-rwxr-xr-x 1 tmaki tmaki 19596 Apr 5 15:51 hadd
-rwxr-xr-x 1 tmaki tmaki 10810 Apr 5 15:51 ssh2rpd
-rwxr-xr-x 1 tmaki tmaki 15423 Apr 5 15:51 roots.exe
-rwxr-xr-x 1 tmaki tmaki 866 Apr 5 15:51 roots
-rwxr-xr-x 1 tmaki tmaki 25431 Apr 5 15:51 h2root
-rwxr-xr-x 1 tmaki tmaki 47582 Apr 5 15:51 g2root

Before you run any ROOT related command you should either (for [ba]sh):
. /Where/My/Root/Is/Installed/bin/thisroot.sh
or (for [t]csh):
source /Where/My/Root/Is/Installed/bin/thisroot.csh
Then “bin/” is added to “PATH” and “lib/” to “LD_LIBRARY_PATH” (and then all executables should be able to find all ROOT related shared libraries -> you might also try to add the “–enable-explicitlink --enable-rpath --enable-soversion” configure flags when building ROOT).