Installing from Source: Problem with CMakeList

ROOT Version: 6.14.04
Platform: Linux Mint 17.1
Compiler: GCC 4.8.4

I am trying to install the latest version of ROOT from source on Linux Mint 17.1, and when I run the first cmake command, I get the following error:

CMake Error: The source “/home/justin/root/CMakeLists.txt” does not match the source “/home/justin/root/test/CMakeLists.txt” used to generate cache. Re-run cmake with a different source directory.

Which file in the source should I use as the source directory? It is not made clear in the installation instructions.

Thank you very much for your help.

Please try with the following in the top directory of your git clone of ROOT:

$ mkdir mybuild && cd mybuild
$ cmake ..
$ cmake --build .

The source directory to use should be the top directory, and the build directory needs to be a different directory (which should be empty to start with). Cheers,

1 Like

Thank you very much! That solved the problem that I was having before, but now I have encountered another issue. When I run the cmake … command, I get the error described in the attached logfile, and I am unsure of what it means. Am I missing missing some required software for Root?CMakeError.txt (3.4 KB)

I had a look at the file, and it looks like your compiler may be too old. Which compiler are you using? You need at least a compiler with full support for C++11. The oldest we support is GCC 4.8.5.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.