Installation woes: undefined reference to '__ctype_b'

I’m trying to install root on a dual opteron machine running Redhat Fedora core 6, as part of a GATE install.

I’m using v5.14.00f, although I initially tried to install v5.12 which is recommended for GATE, receiving the same error.

using the following process:

tar zxvh root_v5.14.00f.source.tar.gz
cd root
set ROOTSYS =(usr/local/root)
./configure linux
gmake install

All seems to go well except the last part where I get the following error (only the last part of the output is here":

==> lib/ done
bin/rmkdepend -R -frootx/src/rootx.d -Y -w 1000 – -pipe -m32 -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -D__cplusplus – rootx/src/rootx.cxx
g++ -O -pipe -m32 -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -DUSEPCH -include precompile.h -o rootx/src/rootx.o -c rootx/src/rootx.cxx
bin/rmkdepend -R -frootx/src/rootxx.d -Y -w 1000 – -pipe -m32 -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -D__cplusplus – rootx/src/rootxx.cxx
g++ -O -pipe -m32 -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -DUSEPCH -include precompile.h -o rootx/src/rootxx.o -c rootx/src/rootxx.cxx
g++ -m32 -O -o bin/root rootx/src/rootx.o rootx/src/rootxx.o -lXpm -lXext -lX11
/usr/lib/gcc/i386-redhat-linux/4.1.1/…/…/…/libXpm.a(parse.o): In function xpmParseExtensions': parse.c:(.text+0x13f8): undefined reference to__ctype_b’
/usr/lib/gcc/i386-redhat-linux/4.1.1/…/…/…/libXpm.a(data.o): In function xpmNextWord': data.c:(.text+0x482): undefined reference to__ctype_b’
data.c:(.text+0x4bf): undefined reference to __ctype_b' data.c:(.text+0x504): undefined reference to__ctype_b’
data.c:(.text+0x51b): undefined reference to __ctype_b' /usr/lib/gcc/i386-redhat-linux/4.1.1/../../../libXpm.a(data.o):data.c:(.text+0x532): more undefined references to__ctype_b’ follow
collect2: ld returned 1 exit status
gmake: *** [bin/root] Error 1
rm cint/lib/dll_stl/rootcint_multimap.cxx cint/lib/dll_stl/G__cpp_list.o cint/lib/dll_stl/G__cpp_multimap.o metautils/src/ utils/src/rootcint_tmp.cxx cint/lib/dll_stl/G__cpp_stack.o cint/lib/dll_stl/rootcint_multimap2.cxx cint/lib/dll_stl/rootcint_vector.cxx cint/lib/dll_stl/rootcint_multiset.cxx cint/lib/dll_stl/G__cpp_exception.o cint/lib/dll_stl/G__cpp_set.o cint/lib/dll_stl/rootcint_list.cxx cint/lib/dll_stl/G__cpp_map.o cint/lib/dll_stl/rootcint_deque.cxx cint/lib/G__c_stdcxxfunc.c cint/lib/dll_stl/rootcint_set.cxx metautils/src/ cint/lib/dll_stl/G__cpp_vector.o cint/lib/dll_stl/G__cpp_multimap2.o cint/lib/G__c_stdcxxfunc.o metautils/src/ cint/lib/dll_stl/G__cpp_queue.o cint/lib/dll_stl/G__cpp_multiset.o cint/lib/dll_stl/G__cpp_deque.o metautils/src/ cint/lib/G__c_stdfunc.o cint/lib/dll_stl/rootcint_map.cxx cint/lib/dll_stl/G__cpp_map2.o cint/lib/dll_stl/G__cpp_complex.o cint/lib/dll_stl/rootcint_map2.cxx metautils/src/ metautils/src/ utils/src/RStl_tmp.cxx metautils/src/ metautils/src/ metautils/src/

From my googling, the ctype_b error is caused by redhat no longer supporting something, but all the solutions seem to be either recompiling the libraries or changing the source code, neither of which are useful to me…

I’m not even sure that the problem is actually in root itself, the error seems to come from libXpm.a, but I’m checked and I have the latest libXpm package (libXpm-3.5.5-3.i386.rpm, compiled for FC6). I’m pretty well stumped here, and I’ve been playing with this installation for weeks now trying to get GATE working.
Can anyone offer any advice?

Well I managed to find the source for the libXpm libraries and after compiling that and installing I got root to install with no errors.

I have $ROOTSYS set to /usr/local/root but there is nothing in there at all?
it all seems to have

Anyhow, I got root working after I ran the bin/thisroot.csh script, before that I got a permission denied error…