Installation problems

Dear Rooters,
I am trying to run root after installation in /opt/root as prefix. Now after configuring :-
export PATH=/opt/root/bin:$PATH
export LD_LIBRARY_PATH=/opt/root/lib:$LD_LIBRARY_PATH

when I run root, it hangs and gives me a message :-

/opt/root/bin/root.exe: error while loading shared libraries: cannot open shared object file: No such file or directory

Could you kindly tell me where is the problem.

Usually ROOTSYS also has to be exported

Thanks Panayotov,
The starting root problem is solved once I exported ROOTSYS before ./configure. But after opening the root box, I got the following message.

Error: cannot open file “RtypesCint.h” FILE:(tmpfile) LINE:2
*** Interpreter error recovered ***
root [0]
Now where is this problem coming from.

try with ./configure --help

Hi Sankar,

to install ROOT with a prefix do:

./configure --prefix=/opt/root
make install

Don’t forget the install step. The install step will copy all files needed to /opt/root (i.e. don’t build in /opt/root). Then to run you should not need to set ROOTSYS. The system knows it was installed in a fixed location. What you need to do is add /opt/root/lib to your LD_LIBRARY_PATH or to /etc/ (so no LD_LIBRARY_PATH is needed).

Cheers, Fons.

Thanks Fons,
Installed and ran root successfully.