Installation: Problem with egrep (problem with CERNlib)

I tried to install ROOT on a Solaris-8 machine (SunOS5.8, Sparc Architecture)

The installation halted with tghe following error message

checking for egrep… configure: error: no acceptable egrep could be found in $PATH

But when I checked egrep, its works.

Please help.

Thanks in advance


The regular egrep Sun uses is not the same than GNU egrep. Some ROOT packages (ROOFit, MathCore, MathMore…) require GNU egrep (it has more options).

Use your GNU egrep, ask your adminsitor where is located the GNU software (perl, emacs, egrep, make…) and this this directory first in your PATH.


Thanks a lot Matthieu. The GNU egrep was not there on my machine and I downloaded the source from GNU ftp and built it.

Now ROOT had no more problem with it.

However I am facing another problem, I don’t have CERNlib installed. But while buuilding ROOT its looking for it. Its using the flag -lmathlib and being unable to find libmathlib.a its terminating with that error message.

I tried to circumvent this problem by getting the CERNlib prebuilt library files and binaries (2002 release were available), but and although the ROOT installation could find the respective library files, still its giving “ld: errors” saying there are undefined symbols in the CERNlib library files.