Installation problem need help

Hi, I try to install root on ubuntu 16.10 but when i insert the command “make” at the and of compilation an error appears that i can’t understand; these are the last line before the compilation stops:

g++ -shared -Wl,-soname, -m64 -O2 -DNDEBUG -Wl,–no-undefined -Wl,–as-needed -o lib/ hist/unfold/src/TUnfoldDensity.o hist/unfold/src/TUnfoldBinning.o hist/unfold/src/TUnfold.o hist/unfold/src/TUnfoldBinningXML.o hist/unfold/src/TUnfoldSys.o hist/unfold/src/G__Unfold.o -Llib -lCore -ldl -Llib -lHist -lMatrix -lXMLParser
/usr/bin/ld: impossibile trovare -lXMLParser
collect2: error: ld returned 1 exit status
/home/andrea/root-6.10.00/hist/unfold/ set di istruzioni per l’obiettivo “lib/” non riuscito
make: *** [lib/] Errore 1

Thank you to all will try to help me

p.s. Have already installed all build prerequisites


first hint: as prompted by the ./configure script, the configure/make build system is deprecated. Please use CMake.
Second hint: are you sure that is really on your system?

D is a part of ROOT, not of the operating system.

sure, just wanted to know if at that point of the build the library was there. In any case, before speculating on some “race” in the build procedure I would recommend to proceed with a CMake driven build.


succeded to install using cmake, thank you!

1 Like

scuse me have an other questions: currently root is installed on my home directory and not in home/root-6.10.00 so that have a lot of disorder in the home; what have to do to change the directory source?


perhaps moving the directory of the build is the only thing which is needed?


Hi, I have the same problem.
I already installed cmake and I tried to lunch the following command line:
cmake /home/daniele/root

but I received the following error:

CMake Error at cmake/modules/RootNewMacros.cmake:873 (message):
** ROOT should be built as an out of source build, to keep the source**
** directory clean. Please create a extra build directory and run the command**
** ‘cmake <path_to_source_dir>’ in this newly created directory. You have**
** also to delete the directory CMakeFiles and the file CMakeCache.txt in the**
** source directory. Otherwise cmake will complain even if you run it from an**
** out-of-source directory.**
Call Stack (most recent call first):

– Configuring incomplete, errors occurred!
See also “/home/daniele/root/CMakeFiles/CMakeOutput.log”.
See also “/home/daniele/root/CMakeFiles/CMakeError.log”.

How you resolved this problem???

Many thanks in advance

Problem solved following the recommendations contained in the file README/INSTALL



the error says it all.
You need to have a build directory outside the sources of ROOT.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.