Installation - performing tests failed

I’m trying to build ROOT 6.08 on Ubuntu 16.04. After downloaded the source code, I ran cmake and installed missing dependencies. But still the following error appears whenever I run cmake.

 -- Performing Test found_stdstringview - Failed
 -- Performing Test found_stdexpstringview
 -- Performing Test found_stdexpstringview - Failed
 -- Performing Test found_stdapply
 -- Performing Test found_stdapply - Failed
 -- Performing Test found_stdinvoke
 -- Performing Test found_stdinvoke - Failed

Could anyone please explain what the problem is and how to solve this?

Try to build the newest ROOT version.

These tests test for C++ features your compiler might already support. std::string_view, std::apply, and std::invoke are C++17 features. The compiler might already support std::string_view in earlier versions, possibly under the name std::experimental::string_view. ROOT has its own implementation of string_view, if the compiler (or the STL implementation that comes with the compiler) does not have it. Therefore “Failed” = the STL you are using does not provide the corresponding feature. No problem though.

1 Like

Thank you very much for the clear answer !

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.