Installation of ROOT 3.10.02 under Windows XP (win32gdk)

Hi there,
I have downloaded ROOT for windows XP (WIN32GDKDEBUG) and
installed as user Administrator.
I can run it fine under Administrator, but when I try to use it as a plain
user, I can open the root windows, but can do very little from there.
For instance if I try to open a browser I get an error message saying that
some file could not be created and nothing else happens (not even a crash!).
I paste here the output of the ROOT windows:


  •                                     *
    
  •    W E L C O M E  to  R O O T       *
    
  •                                     *
    
  • Version 3.10/02 17 December 2003 *
  •                                     *
    
  • You are welcome to visit our Web site *
  •      [root.cern.ch](http://root.cern.ch)            *
    
  •                                     *
    

Compiled for win32gdk.

CINT/ROOT C/C++ Interpreter version 5.15.115, Dec 9 2003
Type ? for help. Commands must be C++ statements.
Enclose multiple statements between { }.
Error: could not create file
Error: could not create file
root [0] TBrowser tb
Error: could not create file
root [1]

I have searched the ROOTALK digest but could not find anything similar.
I have checked as much as I could the environment variables of Administrator and my plain user and could not find any obvious difference.

I am running the program in a directory where I have write access.
I have tried to change the protection of the ROOT directory giving FULL ACCESS to my plain user (same as Administrator), and still the problem is there.

I have the impression that the problem is with trying to establish a command history file somewhere (where?) and not being able to do that.

Is there any other setting I missed during installation?

Any help would be appreciated, thanks

Hi,
cint used to create a tmp file in C:\ (due to a weird MS implementation), see http://root.cern.ch/phpBB2/viewtopic.php?t=119. I don’t know whether Cint now has a workaround for this problem, but you might try a newer root version. Or allow write access to C:\ for everybody. Not nice, but it should fix the problem.
Axel.

That worked. I have the production version 31002, will wait for the next
release. in the meantime I granted access to C:\ to Power Users (which was not the default on my system).

cheers,
Ric