Installation issues ROOT from source on Ubuntu 22.04


I am trying to install root (v6-26-02) from source on Ubuntu 22.04 but I am running into issues.

To reproduce with docker:

docker run -it --rm ubuntu:22.04 /bin/bash

Install required and optional dependencies:

apt-get update
apt-get install -y git cmake ca-certificates curl davix-dev dcap-dev fonts-freefont-ttf g++ gcc gfortran libafterimage-dev libcfitsio-dev libfcgi-dev libfftw3-dev libfreetype6-dev libftgl-dev libgfal2-dev libgif-dev libgl2ps-dev libglew-dev libglu-dev libgraphviz-dev libgsl-dev libjpeg-dev liblz4-dev liblzma-dev libmysqlclient-dev libpcre++-dev libpng-dev libpq-dev libsqlite3-dev libssl-dev libtbb-dev libtiff-dev libx11-dev libxext-dev libxft-dev libxml2-dev libxpm-dev libxxhash-dev libz-dev libzstd-dev locales make python3-dev python3-numpy srm-ifce-dev unixodbc-dev python-is-python3 

CMake build:

ROOT_VERSION=v6-26-02 # currently same version as `latest-stable` branch
git clone --branch=${ROOT_VERSION} /tmp/root/source
mkdir -p /tmp/root/build && cd /tmp/root/build
cmake /tmp/root/source -DCMAKE_CXX_STANDARD=17 -Dgnuinstall=ON
make -j install

There seems to be an error related to XDROOT:

CMake Error at XROOTD-stamp/XROOTD-download-Release.cmake:49 (message):
  Command failed: 1

   '/usr/bin/cmake' '-Dmake=' '-Dconfig=' '-P' '/tmp/root/build/builtins/xrootd/XROOTD-prefix/src/XROOTD-stamp/XROOTD-download-Release-impl.cmake'

  See also


I don’t know how to fix this, according to a quick google search it has something to do with ssl but this should be covered in the dependencies installation. I have also tried with -Druntime_cxxmodules=OFF and I get the same result.

Any idea how I can fix this? Perhaps I am mising some dependency? I am following Dependencies - ROOT.

Do you also get an error if you try with master, instead of latest-stable?

1 Like


that’s a known problem with v6.26.02 (aka latest-stable at the time of writing), it should come up if you search for it on this forum. It’s fixed in master and v6-26-00-patches and it will be fixed in the upcoming v6.26.04 (future latest-stable).


1 Like


In case anyone gets here, this is now fixed in latest_stable now that it was bumped to v6.24.06

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.