Installation Error gitinfo and gdb

_ROOT Version:6.28.10
_Platform: Ubuntu 20.04

Error in < UnknownClass : : ReadGitInfo () >: Cannot determine git info: etc / gitinfo.txt not found!
ERROR in cling :: CIFactory :: createCI():
resource directory / usr /etc // cling /l ib /clang /13.0.0 not found!
fatal error: module map file ‘lib/clang/13.0.0/include/module.modulemap’ not found

*** Break *** segmentation violation
Error in < TUnixSystem :: StackTrace > script / usr / etc / is missing0.

I have tried installing root multiple times but getting this error every time. tried multiple installation methods via building from source to binary installation bu this error persists. I have even tried installing on different physical machines but the same error turns up everytime.

1 Like

Hi Aviral,

Welcome to the ROOT community.
This is very odd. It seems you do not have the compiler corresponding to the binary you are trying to install.
I suggest you try from scratch. Follow the instructions here Installing ROOT - ROOT, try ROOT 6.30.04, once with the binaries ROOT provides, once you installed the dependencies, and if that does not work, through a build from source.
Let us know how this goes, reporting step-by-step what you did and the error you encounter.


Hello Danilo,

I have tried this process once more, but again I ran into the same error. Below is the list of commands I employed, any assistance will be appreciated. I am working with tight deadlines and this seems to hinder my progress
P.S. This is not the first time I am installing root, and every time I have followed the same procedure mentioned below:

34 sudo apt - get install dpkg - dev cmake g++ gcc binutils libx11 - dev libxpm -
dev libxft - dev libxext - dev python3 libssl - dev
35 sudo apt - get install gfortran libpcre3 - dev xlibmesa - glu - dev libglew - dev libftgl - dev libmysqlclient - dev libfftw3 - dev libcfitsio - dev graphviz - dev libavahi - compat - libdnssd - dev libldap2 - dev python3 - dev python3 - numpy libxml2 - dev libkrb5 - dev libgsl0 - dev qtwebengine5 - dev nlohmann - json3 - dev
36 sudo git clone – branch latest-stable – depth = 1 * : // github . com / root-project / root.git root_src
37 mls
38 ls
39 mkdir b_root i_root
40 cd b_root /
41 pwd
42 cd b_root /
43 sudo cmake - DCMAKE _ INSTALL _ PREFIX = / home / aviral / i_root/ /
home / aviral / root_src /
44 sudo cmake – build . --target install -j2
45 cd bin
46 ls
47 source thisroot . sh
48 root
49 history
aviral @ Boson - lite : ~ $ root
Error in < UnknownClass :: ReadGitInfo () > : Cannot determine git info : etc /
gitinfo.txt not found!
ERROR in cling :: CIFactory :: createC I() :
resource directory / usr / etc // cling/ lib / clang / 13.0.0 not found!
fatal error : module map file 'lib / clang / 13.0.0 / include / module . modulemap ’ not found

*** Break *** segmentation violation
Error in < TUnixSystem :: StackTrace > script / usr / etc / gdb - backtrace . sh is missing

It’s hard to tell what is going on. Was the ROOT build configuration and build successful?


Yes indeed!

The installation and build took their own sweet time and when it hit 100 %, I ran my usual root only to get this gitinfo and gdb error every time in the past week.

Could it be something pertaining to GITHUB?

I installed root last month on a different system with the same process and it still works.



Hey Danilo,

I have managed to install and execute ROOT through the snap root-framework, with the following message:

WARNING: cannot start document portal: dial unix /run/user/1000/bus: connect: no such file or directory

Just need help to get around with setting up the system variables.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.