Install ROOT without Xcode

ROOT Version: 6.26.04
Platform: macOS 12.2.1 (Intel)

Hello, I would be trying to figure out if it is possible to install ROOT without having Xcode installed since I don’t use it, and to avoid taking up memory at all I uninstalled it.
I’m following this guide (Building ROOT from source - ROOT), but when I run the command

cmake -DCMAKE_INSTALL_PREFIX=installdir …

I get

CMake Error at interpreter/llvm/src/cmake/modules/CheckAtomic.cmake:53 (message):
Host compiler appears to require libatomic, but cannot find it.
Call Stack (most recent call first):
interpreter/llvm/src/cmake/config-ix.cmake:349 (include)
interpreter/llvm/src/CMakeLists.txt:625 (include)

From the moment that the page (Dependencies - ROOT) shows that

  • Xcode developer package: Xcode is found on the Mac App store. Install command line tools through the XCode preferences and/or running in a terminal xcode-select --install

I suppose that the problem comes from it. I’m using homebrew for installing packages. I list here all the versions of my programs

gcc: stable 11.3.0
cmake: stable 3.23.2
root version that I’m trying to install 6.26.04

Thank you very much for your attention!

Hi @marcogobbo ,

since you are using homebrew already is there a reason why you don’t install ROOT via homebrew as well?

In order to compile ROOT from source I think xcode is required (@Axel can confirm).


Thanks @eguiraud but I’ve already tried. It requires Xcode

brew install root
Running brew update --auto-update
==> Auto-updated Homebrew!
Updated 2 taps (homebrew/core and homebrew/cask).

root: A full installation of is required to compile
this software. Installing just the Command Line Tools is not sufficient.

If you can confirm that I cannot install ROOT without Xcode, I ask you if, after compiling ROOT I need Xcode to use ROOT, or I can uninstall it.

I see. I am not a Mac user but either Axel or @henryiii should have an answer.

Outside homebrew you can build and use ROOT with either the command line tools or the complete Xcode. I have no reason to doubt the homebrew error message :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.