Install Root with

When I am trying to install Root6.24 I got the following error:

/afs/ error adding symbols: File in wrong format
collect2: error: ld returned 1 exit status

The reason is evident, my Root is 64bits but libgsl library 32bits.
There is 64bits but I do not know how to forse cmake to use the correct library.
I tried to use GSL_LIBRARIES variable with no success.
What can I do?

Hi! In this case, you can try to build ROOT with the -Dbuiltin_gsl=ON option. See this file for the full list of build options:

Like this, it will build a custom version of GSL just for ROOT that should always work, independent on what you have on the system.

You need: yum install gsl-devel

Hi Jonas, thank you for the answer.
Yes, I was trying to use "-Dbuiltin_gsl=ON " with no result.
Is it really no option to tell cmake to use the gsl library
which does exist and I know where it is?
I see that this option by default is OFF. Actually I do not care about
Gsl lib, I need only to install Root6. It should be some simple way
how to point it up where the library is placed.
This cmake found wrong library (32bit instead of 64bits).
May be there is a way to search 64bits libraries only?

Hi Wile_E_Coyote,

yum install gsl-devel
I am not experienced in Root6,
What does it mean “yum”

You need to talk to your system administrator.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.