Install root on debian

system: core duo, 32 bit,
debian 4.0, gcc 4.1.2

I tried to install the root 4.17.
It is going well while I dont “install” it (make install).
I got strange errors at this stage:

g++ -shared -Wl,-soname, -m32 -O2 -o lib/ cintex/src/CIN
TClassBuilder.o cintex/src/CINTEnumBuilder.o cintex/src/CINTFunctionBuilder.o ci
ntex/src/CINTFunctional.o cintex/src/CINTScopeBuilder.o cintex/src/CINTTypedefBu
ilder.o cintex/src/CINTUtils.o cintex/src/CINTVariableBuilder.o cintex/src/Cinte
x.o cintex/src/ROOTClassEnhancer.o
.L245' referenced in section.rodata’ of cintex/src/CINTUtils.o: defined in di
scarded section `.gnu.linkonce.t._ZN4ROOT6Cintex9ConverterIlE6toCintEP8G__valueP
v’ of cintex/src/CINTUtils.o

… and many of them …
What is this and how can I cure it?
Is there any advise, hint, suggestion, solution … ?


PS: installation steps:
./configure --prefix=/usr/local/compiled/root/root-5.17
make -j2
make install <- here comes the error …


make install should not link anything. The fact that is tries to shows that something went wrong in the make stage already.

I cannot reproduce what you report. I tried with GCC 4.1.2 on a Debian AMD64 box - I don’t have a 32bit with 4.1.2. The error you see could come from e.g. incompatible object files vs. compiler version, e.g. you compiled 1/2 of ROOT with GCC some-version and the other half with GCC some-other-version.

Alternatively: do you need Reflex and Cintex? If not just pass “–disable-cintex” to configure.

Cheers, Axel.