Install QtRoot with Qt 4.4.1 and MSVC 2008

Hi everybody,

I would like to “install” or maybe built QtRoot using MSVC 2008 compilator and Qt 4.4.1.
I tried to install the 5.18 root bnl .exe package present in the site but when I tried to compile a simple program it showed the same error reported in

Please can you explain me how to install it?

Thank you in advance.

To install Qt 4.4.1 and ROOT on Windows:

  • Install Cygwin (make sure you install all Cygwin components one needs to download and install ROOT. Ask ROOT team if you do not know which one). You may need a few iterations to get all you need.

  • adjust your “cygwin.bat” start scipt to set Visual C++ env

    add there on line:

"call <the directory where your VS lives ">/bin/vcvars32.bat"in front of

(the file name can different for the different VC++ installation)


Goof luck !!!

Hi Fine,

Thank you for your answer, I will try to do that you showed me, but in the same way I will contact bnl root, because I’m very interested (for other reasons) in use qtroot only with VC++ compiler.

Thank you very much,

[quote=“lixo1”]. . . . I’m very interested (for other reasons) in use qtroot only with VC++ compiler. . . . . [/quote]Yes, this bash shell script is to download and build the ROOT and Qt 4.4.1 and QtRoot plugins and some other packages to be used with very VC++ compiler.
You do not need any cygwin to use the libraries and DLL’s the bash shell script is going to build for you. However, you do need Cygwin to build ROOT. See: It says,

[quote=“Install.html”]If you are using Windows make sure you’ve installed Cygwin

and that it is setup correctly, see:[/quote]

A patch from Valeri Fine fixing this problem with Qt4.4.1 has just been put in SVN trunk.


I would like to take this opportunity to thank
Volker Hilsheimer, Global Support Director Trolltech, a Nokia company for his prompt assistance to pin point the origin of the issue. [ TrollTech Issue N224342 ]