Install on Mac

Am using Mac OS X 10.3.2
Have installed most recent version of Root using Fink.
Tried to run root from terminal got error:
root: can’t figure out DISPLAY, set it manually
manually set display

Installed non-standard X11 stuff that comes on Panther disks.
Retried above - same error message

export DISPLAY=x11
Error in TGClient::TGClient: can’t open display “x11”, bombing…

Have used in root in linux and I know I need to set $ROOTSYS in my config file. Is this the problem? If so how do I do it (am new to mac)?
If I do echo $ROOTSYS from the command line i get nothing, so presumable it’s not set now (tried a reboot).

Suggestions welcome…


Which version of ROOT are you running ?

Are trying to run “root” in a window of the "Terminal"
program ? It has no X11 capabilities .

Install the X11 application that come with the Panther disks .

By the way, if I try to run in it in the “Terminal”, it switches
automatically to batch mode:

fatman:~> root
Error in TGClient::TGClient: can’t open display “bla”, switching to batch mode…

  •                                     *
  •    W E L C O M E  to  R O O T       *
  •                                     *
  • Version 4.00/02 29 February 2004 *
  •                                     *
  • You are welcome to visit our Web site *
  •      [](            *
  •                                     *

Compiled for macosx with thread support.

CINT/ROOT C/C++ Interpreter version 5.15.124, Feb 17 2004
Type ? for help. Commands must be C++ statements.
Enclose multiple statements between { }.
root [0]

thanks for the help. in my attempts to install x11 i had put in various overlapping versions which were killing each other. Then I wasn’t actually launching an x11 window anyway - i had presumed it would run automatically from the terminal.
got it going now anyway