Import libPyROOT cause ***stack smashing detected ***: python terminate

Dear ROOT professionals,

I am new to PyROOT. I am running the pyROOT installation on IBM POWER(Ubuntu 14LE). The ROOT version is 5.34.16. My GCC is 4.8.4, Python version is 2.7.6
After install finished (I assume), I ran python and tried to import ROOT. I got the error like this:
Python 2.7.6 (default, Oct 26 2016, 20:22:36)
[GCC 4.8.4] on linux2
Type “help”, “copyright”, “credits” or “license” for more information.

import ROOT
Error in UnknownClass::ReadFile: no file name specified
*** stack smashing detected ***: python terminated
I had a successful installation on Virtualbox(Ubuntu 14 python2.7 gcc4.8). So I did a cross compare with those libs(root/lib), the in VirtualBox has a link to, and looks like most of other *.so files have links to *.so.x. So I am wondering what went wrong during the ./configure make make install steps? or did I miss anything in the ./configure? here is my configure.
./configure linuxppc64gcc --prefix=/opt/root --enable-python --with-x11-libdir=/usr/lib/powerpc64le-linux-gnu --with-xft-libdir=/usr/lib/powerpc64le-linux-gnu --with-xext-libdir=/usr/lib/powerpc64le-linux-gnu --with-xpm-libdir=/usr/lib/powerpc64le-linux-gnu --with-gsl-libdir=/usr/lib/powerpc64le-linux-gnu --with-python-libdir=/usr/lib/powerpc64le-linux-gnu

Any helps? Thanks a lot in advance.

Have you set up the environment?

Including the python path?

Also, you should try to use cmake over configure:

yes. I think the would take care of the environment setup. I didn’t try the cmake though. Don’t know if that would help with the issue. Since the configure make steps worked in virtualBox. I just followed the same steps as I did in virtualbox.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.