I can't pop any window (just installed)


I just installed ROOT in my laptop and got this problem that hadn’t had before (or so I think). I can’t open any window. I see the splash screen but then I try

TBrowser b;

and nothing happens, same with canvas and so on.

Where should I start looking for the missconfiguration problem?



p.s.: ROOT 4.02.00
linux 2.6.8-24.10-default
over SuSE 9.2 (using KDE)

I actually fixed it, but don’t like the way I did it.

It turns out that, even though I set the prefix to a folder I can write, at install it tries to create the folder /etc/root

I guess I could just create a local configuration directory somewhere where these things live in but I didn’t see a configuration option to change that.


I think, It won’t help you, but I have the same SUSE 9.2, (the same KDE etc.) I have /usr/home/tpochep/root - the place, where my ROOT is installed and compiled, I have ROOTSYS env. variable (root/bin and root/lib are added to PATH and LD_LIBRARY_PATH) and everething is OK.

I have ROOTSYS set properly, no problem with libraries or path. The only problem is when I try to open a window. The way I solved it was logging as root to do make install, because if I was not root the thing complained that it couldn’t create the folder /etc/root

Now it works fine, but because I could ‘su’ as root. That shouldn’t be needed and I don’t now how to change it. I would like to install it in another machine where I have no root privileges.

Hi Javier,

when you want to run ROOT from somewhere below your home directory don’t use the --prefix configure option. Just use ./configure.

Please read root.cern.ch/root/Install.html for when and how to use the --prefix option (and see also the remark on /etc/root in that case).

Cheers, Fons.