I can't install root_numpy

_ROOT Version:_6.26/14
_Platform:_Ubuntu 22
Compiler: C++ 11.4


I am trying to install root_numpy for a python project. The problem is that every time I execute conda install root_numpy it crashes due to some incompability issues. At first I thought that the problem was that the version of Python installed in the conda environment was different from which ROOT is compiled. So after doing root-config --python-version I got 3.10.12 so I created a new environment for conda with this version of python by doing conda create --name myenv python=3.10.12 After installing jupyter in this environment I executed import sys print (sys.version) on python, which resulted in 3.10.12. The problem is that the crash still occurs.

The output is this
` Channels:

  • defaults
  • conda-forge
    Platform: linux-64
    Collecting package metadata (repodata.json): done
    Solving environment: | warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    warning libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY
    failed

LibMambaUnsatisfiableError: Encountered problems while solving:

  • package root_numpy-4.8.0-py310ha651d66_16 requires root_base >=6.24.6,<6.24.7.0a0, but none of the providers can be installed

Could not solve for environment specs
The following packages are incompatible
├─ pin-1 is installable and it requires
│ └─ python 3.10.* , which can be installed;
└─ root_numpy is not installable because there are no viable options
├─ root_numpy [4.7.3|4.8.0] would require
│ └─ python >=2.7,<2.8.0a0 , which conflicts with any installable versions previously reported;
├─ root_numpy 4.8.0 would require
│ └─ root_base >=6.24.6,<6.24.7.0a0 but there are no viable options
│ ├─ root_base 6.24.6 would require
│ │ └─ cfitsio >=4.0.0,<4.0.1.0a0 , which conflicts with any installable versions previously reported;
│ ├─ root_base 6.24.6 would require
│ │ └─ cfitsio >=4.1.0,<4.1.1.0a0 , which conflicts with any installable versions previously reported;
│ └─ root_base 6.24.6 would require
│ └─ libcxx >=12,<13.0a0 , which conflicts with any installable versions previously reported;
├─ root_numpy 4.8.0 would require
│ └─ python >=3.6,<3.7.0a0 , which conflicts with any installable versions previously reported;
├─ root_numpy 4.8.0 would require
│ └─ python >=3.7,<3.8.0a0 , which conflicts with any installable versions previously reported;
├─ root_numpy 4.8.0 would require
│ └─ python >=3.8,<3.9.0a0 , which conflicts with any installable versions previously reported;
└─ root_numpy 4.8.0 would require
└─ python >=3.9,<3.10.0a0 , which conflicts with any installable versions previously reported.`

Sorry if the format is not correct, this is my first post :persevere:

Hi,

Thanks for the post and welcome to the ROOT community!
I am sorry to read you are experiencing issues with that package.
Unfortunately, we, ROOT, are not the developer of that package - have you tried to address your inquiry directly to them?

Cheers,
Danilo