I am getting problem when I am installing root

Hi Rooters,

I have downloaded the root version root_v5.34.36.source.tar.gz and trying to install it by following the commands:

1.git clone http://root.cern.ch/git/root.git

2.mkdir mydir

  1. cd mydir

4.cmake -Droofit=ON …/root
5. make -j 8
But After last step I am getting error every time. The error is some like this:
[100%] Generating tutorials/hsimple.root

Processing hsimple.C…
Error in TApplication::ExecuteFile: macro hsimple.C not found in path ~/TMVA/macros
CMakeFiles/hsimple.dir/build.make:66: recipe for target ‘tutorials/hsimple.root’ failed
make[2]: *** [tutorials/hsimple.root] Error 1
CMakeFiles/Makefile2:320: recipe for target ‘CMakeFiles/hsimple.dir/all’ failed
make[1]: *** [CMakeFiles/hsimple.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs…
[100%] Built target HistFactory
Makefile:151: recipe for target ‘all’ failed
make: *** [all] Error 2


Could you please instruct me how to resolve the problem.

ROOT Version: Not Provided
Platform: Not Provided
Compiler: Not Provided

I don’t understand why you clone from git, but downloaded a very old ROOT v5.34?

How does mydir relate to ~/TMVA ?

Cheers, Axel

I was running few tutorials on TMVA. So new files were created. But I deleted everything. Then I tried to re install it but I am getting same error again.


Maybe you deleted too much?

Which directory did you git clone into?

Which directory did you build in?

Cheers, Axel

I am doing git clone in my home directory then move to some mydir and then using other commands. Still I am getting same error even after deleting all.


If you are trying to build ROOT 5.34, you need to do next steps:

1. unpack tar.gz
2. ./configure
3. make -j4

I tried with you command: I am getting error.
cint/cint/lib/stream/iostrm.h:24:10: fatal error: iostream.h: No such file or directory
#include <iostream.h>
compilation terminated.
Makefile:631: recipe for target ‘cint/cint/src/dict/libstrm.o’ failed
make[1]: *** [cint/cint/src/dict/libstrm.o] Error 1
make[1]: *** Waiting for unfinished jobs…
bin/rmkdepend -R -fcore/base/src/TVirtualMutex.d -Y -w 1000 – -pipe -m64 -Wshadow -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -D__cplusplus – /home/souvik/root/core/base/src/TVirtualMutex.cxx
g++ -O2 -pipe -m64 -Wshadow -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -o core/base/src/TVirtualMutex.o -c /home/souvik/root/core/base/src/TVirtualMutex.cxx
bin/rmkdepend -R -fcore/base/src/TAttPad.d -Y -w 1000 – -pipe -m64 -Wshadow -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -D__cplusplus – /home/souvik/root/core/base/src/TAttPad.cxx
g++ -O2 -pipe -m64 -Wshadow -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -o core/base/src/TAttPad.o -c /home/souvik/root/core/base/src/TAttPad.cxx
bin/rmkdepend -R -fcore/base/src/TStyle.d -Y -w 1000 – -pipe -m64 -Wshadow -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -D__cplusplus – /home/souvik/root/core/base/src/TStyle.cxx
g++ -O2 -pipe -m64 -Wshadow -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -o core/base/src/TStyle.o -c /home/souvik/root/core/base/src/TStyle.cxx
bin/rmkdepend -R -fcore/base/src/TVirtualPS.d -Y -w 1000 – -pipe -m64 -Wshadow -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -D__cplusplus – /home/souvik/root/core/base/src/TVirtualPS.cxx
g++ -O2 -pipe -m64 -Wshadow -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -o core/base/src/TVirtualPS.o -c /home/souvik/root/core/base/src/TVirtualPS.cxx
bin/rmkdepend -R -fcore/base/src/TExec.d -Y -w 1000 – -pipe -m64 -Wshadow -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -D__cplusplus – /home/souvik/root/core/base/src/TExec.cxx
g++ -O2 -pipe -m64 -Wshadow -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -o core/base/src/TExec.o -c /home/souvik/root/core/base/src/TExec.cxx
bin/rmkdepend -R -fcore/base/src/TError.d -Y -w 1000 – -pipe -m64 -Wshadow -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -D__cplusplus – /home/souvik/root/core/base/src/TError.cxx
g++ -O2 -pipe -m64 -Wshadow -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -o core/base/src/TError.o -c /home/souvik/root/core/base/src/TError.cxx
make[1]: Leaving directory ‘/home/souvik/root’
cp: cannot stat ‘/home/souvik/root/cint/iosenum/iosenum.linuxx8664gcc’: No such file or directory
/home/souvik/root/cint/cint/Module.mk:309: recipe for target ‘cint/cint/include/iosenum.h’ failed
make: *** [cint/cint/include/iosenum.h] Error 1
make: *** Waiting for unfinished jobs…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.