How to switch off RooFit banner?


I am linking RooFit to my code(inside Atlas framework). During compilation/linking the following RooFit banner is printed three times!!
RooFit v2.31 – Developed by Wouter Verkerke and David Kirkby
Copyright © 2000-2008 NIKHEF, University of California & Stanford University
All rights reserved, please read

Is there a way to switch it off during linking/compilation as well as runtime?

Thanks for your help.


That’s interesting. I’d actually be curious to know why this pops up during compilation and linking as that message is only supposed to be printed when is loaded dynamically by an application.

(I’m a member of ATLAS so feel free to send something that requires ATLAS-specific knowledge to decode)

There is btw no way to switch this of in current releases, but I’ll add this to my to-do list for future releases.


Hi Wouter,

Just wondering if this feature request has propagated to the top of your todo list?



In the latest RooFit release (v3.10, which shipped with the latest ROOT release 5.25/02) you can now disable the generation of these messages if you compile RooFit code with the flag -D__ROOFIT_NOBANNER.