How to get an update from CVS?

I am installing G4UIRoot on Fedora 5 with gcc 4.1.1. When I compile geant4, I received the following errors:

/cern/root/include/Bytes.h: In function ‘void tobuf(char*&, Float_t)’:
/cern/root/include/Bytes.h:222: warning: dereferencing type-punned pointer will break strict-aliasing rules

I tried to get an update through CVS for ROOT since I was using v5.12.00. But when I typed:

cvs -z3 update -d -p

my terminal generated a los of unrecognizable characters and then hang and I had to close my terminal since it is no longer usable. Could you please let me know how to get an update without this problem? Thanks.



from man cvs:

Prune empty directories. See see node `Removing directories’ in the
CVS manual.


Pipe the files retrieved from the repository to standard output,
rather than writing them in the current directory. Available with
the checkout and update commands.

So better use cvs -z3 up -dP :slight_smile:

Cheers, Axel.

I tried “cvs -z3 up -dP” but the result is the same. The terminal is filled with a lots of unrecognizable characters and hang. What is the right command not getting characters on terminal? Well, I just want to get an update in a simple way (I want to avoid reading a manual for cvs). If Bytes.h is the problem, can I just download it from somewhere? Thanks. Hyo


The command I am using is: cvs -q update -dP.

Cheers, Ilka


strange terminal… You can use this link:

Cheers, Axel.

The command “cvs -q update -dp” seems to be working o.k.
The following is the result I have from my terminal.
Thanks very much.


[root@linux cern]# cd root
[root@linux root]# cvs -q update -dP
? test/stressFit
? test/stressGeometry
? test/stressGraphics
? test/stressShapes
? test/stressVector