Home | News | Documentation | Download

How to enable RooFit when installing ROOT from source

I have installed ROOT version 6.10/08 from source. However I am not able to use RooFit. I suspect that I have not provided corresponding flags during the installation. But. After trying to configure as it is said here:

./configure --enable-roofit

configuration done with the message that this build opearation is deprecated and I should use the one that described in the README/INSTALL file. But there I cannot find any instruction how and what flags to provide in order to enable RooFit or any.

Thanks in advance,
Bogdan


Platform, compiler (e.g. CentOS 7.3, gcc6.2): Ubuntu 14.04, gcc 4.8.4


Try to configure it using cmake -Dall=ON ...

Note that the ROOT Team provides ready to use binary distributions, and the “Ubuntu 14 gcc4.8" is one of the supported systems.

So I did

  1. Download and unpack source into directory <rootsrc>
  2. Make and change to directory ROOT
  3. Type cmake -Dall=ON \<rootsrc\>
  4. Type `cmake --build . – -j4

After bulding process I am still not able to use RooFit. Trying to load example in tutorials folder I get the include error:

/home/wolfgang/ROOT/tutorials/roofit/rf101_basics.C:16:10: fatal error: 'RooRealVar.h' file not found
#include "RooRealVar.h"

Try:

root-config --features|grep roofit
root-config --has-roofit

Please note that the ROOT Team provides ready to use binary distributions which do provide “roofit”, and the “Ubuntu 14 gcc4.8" is one of the supported systems.

[ICU]:ROOT> root-config --features|grep roofit
[ICU]:ROOT> root-config --has-roofit
no

Build Prerequisites
Building ROOT

First of all I installed all dependencies (including optional) though most of them have been installed already. Then (assuming the build folder as <build> and source folder as <rootsrc> both in $HOME) I have done:

> cd $HOME/<build>
> cmake -Dall=ON ../<rootsrc>
> cmake --build . -- -j4

where j4 is for my 4 cores.

And it worked. Thank you. Now I can use RooFit.

If you really really really need to build your own binaries then, I think I would recommend you to configure it using at least cmake -Dall="ON" -Dsoversion="ON" and mabye adding -Dcxx14="ON" as well.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.