How can I suppress the terminal output of fit parameters?

I have a macro that performs millions of fits and each fit results in a terminal output of the parameters which is slowing down the whole process. I would very much like to suppress this terminal output (if it’s possible).

Relevant info:
ROOT version: 5.34/36
Linux: Ubuntu 16.04

Thanks a lot


You can use the option “Q” in the TH1::Fit or TGraph::Fit functions

Best Regards


Dear moneta,

thanks a lot… it works perfectly.