Help Setting up Root

Hi all,

I am running Mac OSX 10.13.3. I have just installed root and python using a package manager called Homebrew. I’m having some issues getting python and root to work together. Firstly, let me preface this with I am a newbie, so excuse me if the answer is obvious.

Homebrew put root in /usr/local/Cellar. I also have a “python3” in this directory. Running the python3 in this directory allows me to import root and everything runs smoothly.

However, if I’m not in this directory, python will not import root. I think I know why; I have discovered that homebrew installs python elsewhere on my computer in “usr/local/bin”.
Typing “python” into terminal the python in usr/local/bin, which cannot find root… unless I specify to run the python in usr/local/Cellar.

I think the easiest method to fix this would be to either move root, but where would I move it to?

Any help would be greatly appreciated :slight_smile:


can you try our binaries or a build of ROOT on your system? We do not maintain homebrew distributions.


Gotcha, thank you ! I’m trying to build root now and I could use a clarification. I am on step four of the guide here:

I have made build directory called “builddir” in my home directory. Then I cd into “builddir”, and then I try to run cmake from the root source tree
cmake /Applications/root_v6.12.06

to which bash throws an error
CMake Error: The source directory “/Applications/root_v6.12.06” does not appear to contain CMakeLists.txt.

Clearly I’m not specifying the right path. After doing a search, I found that CMakeLists.txt lives in
and also in

Which one do I need to specify? The online guide doesn’t say. I assume it is the /test one, but I want to be sure.

Thank you!

You should:

cd builddir
cmake -DCMAKE_INSTALL_PREFIX="/full/path/to/where/you/want/to/install/root" -Dall="ON" -Dsoversion="ON" /full/path/to/where/you/unpacked/root/source/code
1 Like

I still get the same error :confused:

Can it be that “/Applications/root_v6.12.06” contains ready to use binaries provided by the ROOT Team and not the source code?

ls -al /Applications/root_v6.12.06
ls -al /Applications/root_v6.12.06/bin
1 Like

Here’s the contents of root_v6.12.06. It looks like its ready to use?

dhcp-v041-174:builddir marcusfirstman$ ls -al /Applications/root_v6.12.06/

total 56
drwxr-xr-x 20 14806 admin 680 Mar 2 10:16 .
drwxrwxr-x+ 86 root admin 2924 Feb 28 18:31 …
-rw-r–r-- 1 14806 admin 26488 Feb 8 23:20 LICENSE
drwxr-xr-x 13 14806 admin 442 Mar 2 10:16 README
drwxr-xr-x 3 14806 admin 102 Mar 2 10:16 aclocal
drwxr-xr-x 42 14806 admin 1428 Mar 2 10:16 bin
drwxr-xr-x 8 14806 admin 272 Mar 2 10:16 cmake
drwxr-xr-x 4 14806 admin 136 Mar 2 10:16 config
drwxr-xr-x 3 14806 admin 102 Feb 9 00:02 emacs
drwxr-xr-x 29 14806 admin 986 Mar 2 10:16 etc
drwxr-xr-x 62 14806 admin 2108 Mar 2 10:16 fonts
drwxr-xr-x 3 14806 admin 102 Feb 9 00:02 geom
drwxr-xr-x 447 14806 admin 15198 Mar 2 10:16 icons
drwxr-xr-x 1670 14806 admin 56780 Mar 2 10:16 include
drwxr-xr-x 363 14806 admin 12342 Mar 2 10:16 lib
drwxr-xr-x 4 14806 admin 136 Mar 2 10:16 macros
drwxr-xr-x 3 14806 admin 102 Feb 9 00:02 man
drwxr-xr-x 115 14806 admin 3910 Mar 2 10:16 test
drwxr-xr-x 3 14806 admin 102 Feb 9 00:02 tmva
drwxr-xr-x 69 14806 admin 2346 Mar 2 10:16 tutorials

Yes it is indeed ready to use. I can run root from terminal. I guess steps 4-6 are not needed for the latest version of root.

Thank you for your help!

You unpacked a ready to use BINARY distribution for your system (make sure that your operating system version and the compiler exactly correspond to the version that you unpacked), and NOT the SOURCE code (which you would need to compile).

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.