HELP - error when running C file on cluster using conda environment for root

Hi everyone,

I’m trying to analyse some event results with root on a cluster in my university. To do that, I created an conda environment for root following this: https: // .ch/t/error-while-loading-library-libcore-so-in-cluster/26336
With the environment activated, I tried to execute an C code to make an root pT spectra with my results, but I get the following: error while loagin shared libraries: cannot open shared object file: No such file or directory
I tried to solve this following this: https:/ / .ch/t/error-while-loading-library-libcore-so-in-cluster/ 26336
But I had no success.
My root is in Rint:/
The version is 6.28/00

Thank u!

Hi @isabelleaguiar,

welcome to the forum! Could you please elaborate what exactly you tried?

You’re also quoting the same link twice, but I’m assuming you followed the conda installation from here: Installing ROOT - ROOT


Hi Marta,

I thought that I’ve linked the another tutorial that I followed. Sorry about that! Basically, I followed the conda installation then I followed the part of the manual that explains how to set the environment variables, but when I try to compile my script it says that I dont have some libraries needed for root, like libCore. I’m trying to install manually with conda, but even after installing it keeps saying the library is missing.


I guess, after you “activate” the conda environment, everything is set up (no need for additional steps to set any environment variables).

Sorry, I forgot to said that it’s happened with the environment activated.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.