Help installing Delphes on Mac OS 10.15


I’m trying to use Delphes on my Mac OS 10.15.7 installation. Madgraph5 and pythia8 are installed without problems. I then installed root via the mamba package manager (no apparent problems during install), and then tried to install Delphes by running “install Delphes” within the mg5 prompt. This gave me the compilation error described here

I deleted the VERSION file as indicated but this did not fix the problem. I then tried installing root via homebrew (no apparent problems during install) but the ROOTSYS variable does not get updated to the homebrew version, and if I try and do it manually by adding

export ROOTSYS=/usr/local/Cellar/root/6.22.08_2
export PATH=$ROOTSYS/bin:$PATH

to my .bashrc and running source .bash_profile before trying to make Delphes, that does not change anything either (except that instead of accessing the mambaforge version of root the make script now goes to the homebrew one, but the same problem persists).

(I’m not very knowledgeable on bash issues like compiler linking and setting of environmental variables etc, and I hope I have not jumbled things up too badly by installing two root versions with two package managers.)

Does anyone know how I might successfully install root + delphes in Mac OS 10.15.7? Thanks a lot for your help!!

update: this was fixed by using the CERN .pkg root v 6.20 binary
thanks to Olivier for solving this

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.