Have anybody successfully built the Debian packages?

As the title.
I encountered too many errors while trying to build the debian packages of 5.28.00 on Squeeze. :frowning:
It seems that nobody is responsible for Debian Support. Sad.


If you are able to fix some of those issue, we will gladly incorporate your fixes in the repository.



I have also been struggling with making the debian package from ROOT 5.28 the last weeks and solved few issues (but still not finished). What is the best way to report them? Through this forum? Can someone more experienced in ROOT check them, please?

The first issue many people have reported here already is that when running “make debian” the ROOT_SRCDIR and ROOT_OBJDIR variables are not set. So in the general Makefile I added there the definition:

ifeq ($(findstring $(MAKECMDGOALS), maintainer-clean debian redhat),) include config/Makefile.comp else ROOT_SRCDIR=$(shell pwd) ROOT_OBJDIR=$(shell pwd) endif

Another rather simple bug was this one:
[codedebian/rules debian/control
./build/package/lib/makebuilddepend.sh: line 322: test: -gt: unary operator expected][/code]

the culprit is in makebuilddepend.sh:

if test $need_krb5 -gt 0 ; then echo -n ", libkrb5-dev|heimdal-dev" fi

which is caused by undefined $need_krb5.
So in makebuilddepend.sh just added:



Also it seems (to my limited knowledge) that in the build/package/debian/control file some of the packages are missing or are obsolete. I made a little update, not sure whether it is complete:

[code]Build-Depends: debhelper (>= 7), po-debconf, libssl-dev, comerr-dev, libxpm-dev, libfreetype6-dev, libpcre3-dev, zlib1g-dev | libz-dev, python-dev (>= 2.1), graphviz, libxft-dev, libxext-dev, libx11-dev, libstdc++6-4.3-dev, libc6-dev, @builddepends@
Standards-Version: 3.8.0
Homepage: http://root.cern.ch

Package: root-system
Architecture: any
Depends: root-system-bin, libroot-core-dev, ${shlibs:Depends}, ${misc:Depends}
Recommends: @plugins@, x11proto-xext-dev, ncurses-dev, libpcre3-dev, xlibmesa-glu-dev, libglew1.5-dev, libftgl-dev, libmysqlclient-dev, libfftw3-dev, graphviz-dev, libavahi-compat-libdnssd-dev, libldap-dev, libxml2-dev, libssl-dev, libgsl0-dev, graphviz, cernlib, gccxml, libqtcore4, libqtgui, libqt4-dev, qt4-dev-tools
Suggests: @extras@[/code]

The new packages were obtained from already installed ROOT (compiled as usual from source) as follows:

[code]$ objdump -p /usr/local/bin/root | grep NEEDED

NEEDED libXpm.so.4
NEEDED libXext.so.6
NEEDED libX11.so.6
NEEDED libXft.so.2
NEEDED libstdc++.so.6
NEEDED libm.so.6
NEEDED libgcc_s.so.1
NEEDED libc.so.6

For each library listed here we execute dpkg -S and get the dev versions. This makes a list: libxpm-dev, libxext-dev, libx11-dev, libxft-dev, libstdc++6-4.3-dev, libc6-dev, libc6-dev.

Another problem was this one

debian/rules debian/control *** Warning *** Unknown package root-plugin-graf2d-gviz - please update ./build/package/lib/makebuilddepend.sh

Looking into the package it seems there is no need to add some dependency (I might be wrong though), so I added into the file build/package/lib/makebuilddepend.sh twice the line

RooFit seemed to be too difficult to get it compiled with “make debian”, so I have removed it from configuration options. The options in build/package/debian/rules now look as:

CONFOPTIONS :=--enable-soversion \ --with-glew-incdir=/usr/include/GL \ --with-ftgl-incdir=/usr/include/FTGL \ --with-ftgl-libdir=/usr/lib/ \ --disable-builtin-ftgl \ $(BUILDOPT)

Another problem was with the libFTGL.so. The configure script correctly found that we do not want to build its internal version, but stil the dh_install required that downstream. The solution was rather dirty: deleted graf3d/ftgl/Module.mk.

Then I encountered problem with PROOF libraries, which I have not really solved…

Any comments or bug fix suggestions are really welcomed! I will try to contact Christian Holm too …