Have a problem using ACLIC of v6.08.00


I have downloaded into my MacBook Air the binary file root_v6.08.00.macosx64-10.12.tar.gz
from root.cern.ch/content/release-60800
I have decompressed it in my directory Downloads using the command
tar -xzvf root_v6.08.00.macosx64-10.12.tar.gz
It gave me a directory /Users/elemernagy/Downloads/root
I put a line in my .login file:
source Downloads/root/bin/thisroot.sh
I have issued a command
source .login
and started to execute root in a directory
root -x CardDa,C
worked fine.
However when trying ACLIC in a root session it ended with the following error:
elemers-macbook-air:bridge elemernagy$ root

| Welcome to ROOT 6.08/00 root.cern.ch |
| © 1995-2016, The ROOT Team |
| Built for macosx64 |
| From tag v6-08-00, 4 November 2016 |

Try ‘.help’, ‘.demo’, ‘.license’, ‘.credits’, ‘.quit’/’.q’

root [0] .x CardDa.C++
Info in TMacOSXSystem::ACLiC: creating shared library /Users/elemernagy/work/bridge/./CardDa_C.so
warning: no such sysroot directory: '-I/Users/elemernagy/Downloads/root/etc’
In file included from input_line_3:1:
In file included from /Users/elemernagy/Downloads/root/include/RtypesCore.h:24:
/Users/elemernagy/Downloads/root/include/RConfig.h:276:13: fatal error: ‘AvailabilityMacros.h’ file not found

include <AvailabilityMacros.h>


*** Break *** segmentation violation
Error in : Dictionary generation failed!
root [1]

I would appreciate somebody tells me what did I wrong.


PS BTW the above procedure worked fine w/o error with an old version:
so I suspect that something has changed since this version, and especially in v6.08/00.

Did you install latest Xcode and the command line tools?

If you mean by Xcode X11, yes, I have the latest one.
On the other hand I don’t know what you mean by Command Line Tools.

To install the command line tools you need to run ‘xcode-select --install’ from a terminal.
See root.cern.ch/build-prerequisites#macosx

Many thanks for this good suggestion, now also ACLIC works w/ v6.08/00.
Best, Elemer