Hadd create empty output file

Dear all,

I’m trying to merge some rather large root files but get empty output file without any error messages.

I sourced root 6 from

source /afs/cern.ch/sw/lcg/app/releases/ROOT/6.06.08/x86_64-slc6-gcc49-opt/root/bin/thisroot.sh

and this is the merge command:

 hadd -f -v out.root D2hMuMu11_MagD_2PiMuMuOS_NTuple_Reduced.root D2hMuMu11_MagU_2PiMuMuOS_NTuple_Reduced.root D2hMuMu12_MagD_2PiMuMuOS_NTuple_Reduced.root D2hMuMu12_MagU_2PiMuMuOS_NTuple_Reduced.root
hadd Target file: out.root
hadd compression setting for all ouput: 1
hadd Source file 1: D2hMuMu11_MagD_2PiMuMuOS_NTuple_Reduced.root
hadd Source file 2: D2hMuMu11_MagU_2PiMuMuOS_NTuple_Reduced.root
hadd Source file 3: D2hMuMu12_MagD_2PiMuMuOS_NTuple_Reduced.root
hadd Source file 4: D2hMuMu12_MagU_2PiMuMuOS_NTuple_Reduced.root
hadd Target path: out.root:/
hadd Target path: out.root:/D2PimumuOSTuple

The output file out.root is empty.

I’m doing this on CERN EOS.

Any suggestion how to fix or more information about the problem would be great!

Hi Xiaoli,

are you using the eos fuse mounted on lxplus nodes?
In order to exclude io backend problems, would it be possible to try and merge in the /tmp directory?


Hi dpiparo,

Yes I’m using eos on lxplus, I tried to merge in /tmp and it worked! Thanks a lot!!

Now I have problem moving it to my directory…

mv out.root /eos/user/c/chenx/analysis-case-study/scripts/1_preselection/

and get input/output error after 25 minutes:

mv: closing `/eos/user/c/chenx/analysis-case-study/scripts/1_preselection/out.root': Input/output error

I will try other ways to move it and hopefully it’s not against any computing rules to leave a massive file in /tmp/


thanks a lot for the perseverance. I am communicating this issue to the eos experts in the CERN Storage group since I suspect that here ROOT is not part of the equation.


This problem was in the end solved by raising the EOS single file size limit (done by CERN IT). The default was set to 10G, one can request an increase of the threshold.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.