H2root in root

The root version is : 5.16/00
I ran the configure and “gmake” and I have been using this verison w/o any problem. But I tried doing the following ( I am using h2root for the first time)

root [1] h2root events_8.5.dat events_8.5.root
Error: Symbol h2rootevents_8 is not defined in current scope (tmpfile):1:
Error: Failed to evaluate h2rootevents_8.5
Error: Failed to evaluate h2rootevents_8.5.datevents_8
Error: Failed to evaluate h2rootevents_8.5.datevents_8.5
Error: Failed to evaluate h2rootevents_8.5.datevents_8.5.root

Is this the correct way to use h2root ? do i have to run something else in order to make this work.
-thanks Debdatta.

Hi Debdatta,

Use h2root OUTSIDE root, not in a root session (it is a regular executable)


Hi Bertrand,
thanks for your reply. I just tried running it from outside and I still get the message that the command does not exist. I am not running it from the dir. where i installed root but from a different dir. where ROOTSYS is defined.

Please check that h2root exists in $ROOTSYS/bin and that you have $ROOTSYS/bin in your PATH

Cheers, Bertrand.

Hi Bertrand,
the h2root executable doesn’t exist in my $ROOTSYS/bin dir. Do I have to something other than make to get it ?

you must call ./configure with-cern-libdir=your_cernlib_location to be able to convert hbook files to root files. (that means that you must have cernlib installed on your system, or accessible somewhere (i.e. afs…)


I just ran(w/o explicitly linking cernlib): ./configure
and the part that I think links the cernlib is:

Checking for libpacklib_noshift, libpacklib, packmd, or packlib …/projects/903/debdatta/genie-installation/ext/CERN/2004/lib

Checking for libkernlib_noshift, libkernlib, kernmd, or kernlib … /projects/903/debdatta/genie-installation/ext/CERN/2004/lib

Checking for rfio in /projects/903/debdatta/genie-installation/ext/CERN/2004/lib/libpacklib_noshift.a … no

so it seems it cant find rfio, could that be causing the problem ?

mmm… maybe, I will have to check tomorrow at CERN.
I’ll let you know, unless someone post a solution before :wink:


libpacklib_noshift is needed, please check if it’s there.


HI Bertrand,
I checked that particular library does exist.