H2root compilation

I tried to compile root4.03/02. For default ./configure file everything looks good. But only these programs appeared in root/bin directory:
cint makecint olbd proofserv
rmkdepend root-config rootcint rootn.exe
xrootd hadd memprobe proofd
rlibmap root root.exe rootd

I need another program h2root to convert Pythia6 ntpl to RootTree. According to instruction (./configure --help) I run command
./configure --enable-cern after that I did ‘make’ and ‘make install’ but nothing changed. What did I incorrect? Thank you in advance.

You seem to have an old version of CERNLIB (see result of configure)


I changed cernlib version on newest one (cernlib/2004). Now it works! h2root appeared in root/bin. Thank you.

But I got another problem. When I try to use h2root I get the message:
h2root: error while loading shared libraries: libshift.so: cannot open shared object file: No such file or directory

Actually, libshift.so is not in cernlib package. How can I get it? Thank you in advance.

see root.cern.ch/root/Install.html
for the list of optional libs
On lxplus shift is installed in /usr/local, the include file "rfio_api.h"
is in /usr/include