GSLIntegrator and GSL libraries for macosx

Dear ROOTers,
I compiled a code that uses ROOT::Math::GSLIntegrator but when it calls
the routine GSLIntegrator doesn’t work. I tried also to call it directly in
CINT but it seems not be present (using TAB to know the content of
ROOT::Math:: I obtain the same result).
I don’t know if it happens for other Mac users but it seems also that I’m
able to compile ROOT with GSL but later it seems that it is not possible
to call back that compiled function.
I tried to use several precompiled ROOTs (2.27,2.26,…) but there is no
chance to use GSLIntegrator or other GSL objects.
My system is:
MacBookPro
Macosx i386 32bit, Darwin 10.2.0.

Here I advice a problem that could be related. When I run

./configure macosx

the system compile some libraries for 32bit and some others using
x86_64 !!! But my architecture is still 32bit even if I could upgrade
it to 64bit.
I found that, perhaps, one of the bugs in ./configure is due to

    sysctl machdep.cpu.extfeatures ...

that gives back

    machdep.cpu.extfeatures:  SYSCALL XD [b]EM64T[/b]

and so the script reset the arch to:

    arch=macosx64

Cheers
Andrea

Hi,

if you have built ROOT for a 64 bits architecture (i.e .the compiler flag -m64 is used) you need to build also GSL with -m64. Download GSL from ftpmirror.gnu.org (then subdirectory GNU/GSL ) and then before configuring it, re-define the compiler flags with -m64. Do for instance:

and then you re-configure ROOT with

Remember, also to use the MathMore classes in CINT and have them visible using TAB, you need to do first

gSystem->Load("libMathMore")

Best Regards

Lorenzo