“GLXBadContextTag” Error from EVE


When I call eve related functions from python using ROOT.gInterpreter.ProcessLine() , the following errors happened:

Error in <RootX11ErrorHandler>: GLXBadContextTag (TGLWidget XID: 100665087, XREQ: 152)
TGLWidget:	100665087
	TGVerticalFrame:	100665082
	TGLSAFrame:	100665071
	TGCompositeFrame:	100665070
	TEveCompositeFrameInPack:	100665062
	TGPack:	100665061
	TEveCompositeFrameInTab:	100665054
	TGCompositeFrame:	100665053
	TGTab:	100663604
	TGHorizontalFrame:	100663595
	TGVerticalFrame:	100663594
	TGHorizontalFrame:	100663592
	TGVerticalFrame:	100663581
	TEveBrowser:	100663580
connection filed, displaying last result
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.7/threading.py", line 801, in __bootstrap_inner
  File "/usr/lib/python2.7/threading.py", line 754, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/home/yanghang/Program/root/root_install/lib/ROOT/_application.py", line 91, in _process_root_events
SystemError: bool TSystem::ProcessEvents() =>
    SystemError: problem in C++; program state was reset

The functions I called is about initializing eve views and they worked fine when I called them directly from root. Also, calling them from python worked fine on another computer. After these errors, the eve window was still there but inresponsive.

My ROOT version is 6.22

Did you try to search the forum for GLXBadContextTag? Otherwise @matevz may be able to help you

Yes, there are similar problems on the forum and I did tried some of their solutions, unfortunately the error remains…

So let’s see if @matevz can help

Hi guys,

I’ve never tried running Eve (or anything, really) via python. You say regular C++ script works ok and that even the python script works on another computer. This is rather strange :slight_smile:

Can you show us some more of your code so somebody who knows more about PyRoot can try it out? Minimal code that reproduces the problem would be ideal.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.