Getting root 5.34/01 to run with python 2.7.3

I recently installed root 5.34/01 on a new installation of Fedora intending to run it with python. My Fedora version had python 2.7.3 preinstalled. The root installation has python enabled, and I can find the libraries I need when looking in the correct folders. The problem seems to be that the ROOT.py script called when I run ‘import ROOT’ at the python prompt only looks for libpython2.6.so.1.0, when the file I in fact have on my machine is libpython2.7.so.1.0. I tried to fix this by changing the ‘version’ designation in the ROOT.py file from 6.1.0 to 7.1.0, but the code still looks for the libpython2.6.so.1.0 file. Any advice on how I can fix this would be appreciated.

import ROOT
Traceback (most recent call last):
File “”, line 1, in
File “/usr/local/root/lib/ROOT.py”, line 85, in
import libPyROOT as _root
ImportError: libpython2.6.so.1.0: cannot open shared object file: No such file or directory

Try:
ldd root-config --libdir/libPyROOT.so | grep -i python
It seems to me that you took a “ready to use” binary release which was created on another system. If this is the case, you need to configure and compile your ROOT from scratch on your own machine.